Kruscal: Agri-Net

B - Agri-Net
Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28


用Kruscal算法最小生成树时注意一条边一条边输入,不用的边别输入;

事先要对每个顶点的父亲情况初始化一下,即p[i] = i ;

基本思想是先把所有边按长短排序,小的在前,再每条边的两个顶点依次遍历,如果祖先不同则把边的权值加进去,再合并,即前者祖先为后者祖先。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>

using namespace std;

int n;
int cnt;
int p[110];
int ans;

struct edge{
    int u;
    int v;
    int w;
    int p;
}e[10010];

int find(int x){
    return p[x] == x ? x : p[x] = find(p[x]);
}

int cmp(edge a , edge b){
    return a.w < b.w;
}

int Kruskal(){
    ans = 0;
    int i;
    for(i = 0; i < n; i ++)
        p[i] = i;
    sort(e + 1, e + cnt  + 1, cmp);
    for(i = 1; i <= cnt; i ++){
        int x = find(e[i].u);
        int y = find(e[i].v);
        if(x != y){
            ans += e[i].w;
            p[x] = y;
        }
    }
}

int main(){
    int i, j, aa;
    while(~scanf("%d", &n)){
        cnt = 0;
        for(i = 0; i < n; i ++){
            for(j = 0; j < n; j ++){
                if(j <=  i)
                    scanf("%d", &aa);
                else{
                    scanf("%d", &e[++cnt].w);
                    e[cnt].u = i;
                    e[cnt].v = j;
                }
            }
        }
        for(i = 0; i < n; i ++)
            p[i] = i;
        Kruskal();
        cout << ans << endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值