并查集,贪心:Color A Tree

C - Color a Tree
Time Limit:1000MS    Memory Limit:30000KB    64bit IO Format:%I64d & %I64u

Description

Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes.

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try.

Each node has a "coloring cost factor", Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi.

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33.

Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.

Input

The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed.

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed.

Output

For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.

Sample Input

5 1
1 2 1 2 4
1 2
1 3
2 4
3 5
0 0

Sample Output

33
题目样例分析:
粉刷顺序与合并顺序是不一样的,
粉刷顺序为: 1,3,5,2,4
合并顺序为:
          fa          num_node(包含点数) sumc(当前权值) ans(当前花费)
5         3              1                 4                4         他父亲(3)加4+4
3         1              2                 5                9         他父亲(1)加14=9*1+5
2         1              1                 2                2         他父亲(1)加8=3*2+2
4         1              1                 2                2         他父亲(1)加10=4*2+2
最后33 = 1 + 14 + 8 + 10

 
 

/*
贪心的总体思路是:每次找到一个权值最大的节点,如果它是根节点,则首先对它染色,
否则的话我们可以得出一个结论,在对它的父亲已经染色的情况下,立刻给它染色是最优的。
现在重点讨论第二种情况,当它不是根节点时,我们如果对它父亲染了色,则一定会立刻对它染色,
所以可以把它和它父亲合并为同一个节点,它和它父亲的儿子都成为了新节点的儿子,它的父亲的父亲则是新节点的父亲。
为了能继续贪下去,我们给每个节点赋上两个权值,
num_node表示对第i个节点图色所需的时间(第i个节点实际包含的节点数),sumc表示第i个节点的总权值(第i个节点实际包含的节点的权值和)。
此时,我们定义一个节点的权值就等于sumc比上num_node。
我们可以证明在新的权值的定义下,上文的贪心同样成立(实际上,上文的贪心和在新定义的权值的情况下的贪心的证明是一样的)。
这个证明有点类似一个叫轮换不等式的东西
*/
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 1005;

struct node
{
    int num_node;  //此集合中包含点数
    int father;    //父亲
    int sumc;       //总权值
    int ans;        //它和它的子节点所用花费
    int flag;       //表示它已访问过
} Tree[N];

int Find (int p)//并查集合并节点
{
    if (p != Tree[p].father && Tree[Tree[p].father].flag){ //Tree[p].father如果不是根节点且Tree[p].father已粉刷就能继续往下找
        Tree[p].father = Find(Tree[p].father);   //它的父亲变成父亲的祖先
    }
    return Tree[p].father;  //返回它“最后的”父亲的编号,不一定是根节点
}
int main()
{
    int r,n,a,b,indexn,father,k;
    double maxv;
    while(scanf("%d%d",&n,&r), n || r ){
        memset(Tree,0,sizeof(Tree));
        for(int i=1; i<=n; i++){
            scanf("%d",&Tree[i].sumc); //权值
            Tree[i].ans = Tree[i].sumc;
            Tree[i].num_node = 1;
        }
        for(int i=1; i<n; i++){
            scanf("%d%d",&a,&b);
            Tree[b].father = a;
        }
        Tree[r].father = r;
        //printf("tree1:%d\n", Tree[1].flag);
        for(int i=1; i<n; i++){ //循环n-1次把每个点按顺序合并,注意这不是粉刷顺序
            maxv = 0;
            for(int j=1; j<=n; j++){
                if(!Tree[j].flag && maxv < Tree[j].sumc*1.0/Tree[j].num_node && j != r){
                    indexn = j;
                    maxv = Tree[j].sumc*1.0/Tree[j].num_node;
                }
            }
            Tree[indexn].flag = 1;   //表示已合并
            father = Find(indexn);   //找能找到最高长辈,不一定是根节点
            //printf("\n%d %d %d %d %d\n",indexn, father, Tree[indexn].num_node, Tree[indexn].sumc, Tree[indexn].ans);//以下为轮换不等式
            Tree[father].ans += Tree[indexn].ans + Tree[indexn].sumc * Tree[father].num_node;
            //重要:父亲的总花费=孩子总花费+孩子总权值*父亲的顺序值
            Tree[father].sumc += Tree[indexn].sumc; //父亲的总权值得加上孩子的总权值
            Tree[father].num_node += Tree[indexn].num_node;//父亲的顺序值要加上孩子的顺序值,注意这要在算完父亲总花费后
        }
        printf("%d\n",Tree[r].ans);
    }
    return 0;
}


  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值