DP三进制状态压缩:Travelling

B - Travelling
Time Limit:3000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input

There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output

Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input

    
    
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output

    
    
100 90 7
 
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <string>

    using namespace std;

    #define INF 1<<31-1
    int tri[12]= {0,1,3,9,27,81,243,729,2187,6561,19683,59049};//三进制1表示去过一次,2表示2次,0表示没去过
    int dp[59050][12];
    int dig[59050][12];//状态i是0到59049,j是城市编号,dig[i][j]指的是状态为i时城市j被访问了多少遍
    int edge[12][12];

    int main(){
        int n, m;
        int i, j;
        int ans;
        for(i = 0; i < 59050; i ++){
            int tmp = i;
            for(j = 1; j <= 10; j ++){
                dig[i][j] = tmp % 3;
                tmp = tmp/3;
            }
        }
        while(cin >> n >> m){
            ans = INF;
            for(i = 1; i <= n; i ++){
                for(j = 1; j <= n; j ++)
                    edge[i][j] = INF;
            }
            for(i = 0; i < tri[n+1]; i ++){
                for(j = 1; j <= n; j ++){
                    dp[i][j] = INF;
                }
            }
            for(i = 1; i <= 10; i ++){
                dp[tri[i]][i] = 0;//边界条件,状态为只遍历了i城且身处在i城时走过的路为0
            }
            for(i = 1; i <= m; i ++){
                int a, b, c;
                scanf("%d %d %d", &a, &b, &c);
                if(edge[a][b] > c){
                    edge[a][b] = c;
                    edge[b][a] = c;
                }
            }
            for(int s = 0; s < tri[n+1]; s ++){
                int vis_all = 1;//判断在这种情况是有效的,所有城市都被访问了
                for(i = 1; i <= n; i ++){
                    if(dig[s][i] == 0)
                        vis_all =0;//S状态下i城没访问过,则S不能作为终状态
                    if(dp[s][i] == INF)
                        continue;
                    for(j = 1; j <= n; j ++){
                        if(i == j)
                            continue;
                        if(edge[i][j] == INF || dig[s][j] == 2)//i与j相等或者i走不到j或者j城已走过两遍
                            continue;
                        int ns = s + tri[j];
                        dp[ns][j] = min(dp[ns][j], dp[s][i] + edge[i][j]);
                    }
                }
                if(vis_all)
                for(j = 1; j <= n; j ++){
                    ans = min(ans, dp[s][j]);//S能作为终状态时,比较落脚在那个点要走的路最少
                }
            }
            if(ans == INF)
                cout << "-1" << endl;
            else
                cout << ans << endl;
        }
        return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值