hdu3001 travelling

Travelling

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2524    Accepted Submission(s): 738


Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
  
  
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
  
  
100 90 7
 

Source
 

Recommend
gaojie
 

Statistic |  Submit |  Discuss |  Note

这是队友写的我还没搞懂所以先转过来以后好看看
Memory: 7228 KB Time: 359 MS Language: G++ Result:  Accepted
#include <iostream>
#include <stdio.h>
using namespace std;
int threenum[11]={1,3,9,27,81,243,729,2187,6561,19683,59049};
#define inf 0x4f4f4f4f
int dp[600000][15],n,m;
int threeevery[600000][15],dis[15][15];
int fmin(int x,int y){if(x<y)return x;return y;}
void makethree()//先预处理,算出所有的值
{
    int i,temp,j;
    for(i=0;i<threenum[10];i++)//3的11次之内的所有状态
    {
        temp=i;
       for(j=0;j<10;j++)
       {
           threeevery[i][j]=temp%3;//写出i的三进制
           temp=temp/3;
       }
    }

}
void init()
{
    int i,j,s,e,val;
    for(i=0;i<threenum[n];i++)
    {
        for(j=0;j<n;j++)
        {
            dp[i][j]=inf;
        }
    }
    for(i=0;i<n;i++)
        for(j=0;j<n;j++)
            {
                dis[i][j]=inf;
            }
      for(i=0;i<n;i++)
    {
        dp[threenum[i]][i]=0;//到自已的点初始化为0
    }

    for(i=0;i<m;i++)
    {

            scanf("%d%d%d",&s,&e,&val);
            s--;e--;//全部从0开始
           // if(dis[s][e]==-1)
            //{
            //    dis[s][e]=dis[e][s]=val;
            //}
            //else
             if(val<dis[s][e])
                dis[s][e]=dis[e][s]=val;//排除重边取最小值

    }

}
int makedp()
{
    int i,j,k,minx;
    bool flag;
    minx=inf;
    for(i=0;i<threenum[n];i++)//对于每一位都要计算
    {
        flag=true;//标记是否每一个点都已经经过
        for(j=0;j<n;j++)
        {
            if(threeevery[i][j]==0)//是这个点没有走
                flag=false;
            if(dp[i][j]==inf)//没有走过
            {
                continue;
            }
            for(k=0;k<n;k++)//加入k这个点
            {
                if((j==k)||threeevery[i][k]>=2||(dis[j][k]==inf))//自已到自已的地方,经过超过两次,不相连通去掉
                continue;
                dp[i+threenum[k]][k]=fmin(dp[i+threenum[k]][k],dp[i][j]+dis[j][k]);//从j到k
            }

        }
        if(flag)//满足条件,对最小值进行更新
        {
            for(j=0;j<n;j++)
            {
                minx=fmin(dp[i][j],minx);
            }
        }
    }
    if(minx==inf)
    {
       minx=-1;
    }

    printf("%d\n",minx);
    return 1;
}
int main()
{
    makethree();
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        makedp();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值