DP单调队列:Max Sum of Max-K-sub-sequence

Max Sum of Max-K-sub-sequence Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

Output

For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 

Sample Input

     
     
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 

Sample Output

     
     
7 1 3 7 1 3 7 6 2 -1 1 1
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

#define N 100010
#define INF 1<<31-1;
int a[2*N], sum[2*N];
int num[2*N];

int main(){
    int n, k;
    int beg, end;
    int i, j, h, t;
    int maxn;
    int cnt;
    scanf("%d", &cnt);
    while(cnt --){
        scanf("%d %d", &n, &k);
        sum[0] = 0;
        for(i = 1; i <= n; i ++){
            scanf("%d", &a[i]);
            sum[i] = sum[i-1] + a[i];
        }
        for(i = n+1; i <= 2*n; i ++){
            sum[i] = sum[i-1] + a[i-n]; //因为是循环的数组,所以要拓展一下
        }
        maxn = -INF;
        beg = 0; end = 0;
        h = 0;
        t = 0;
        for(i = 0; i < n + k; i ++){
            while(h < t && sum[num[t-1]] > sum[i])
                t--;
            num[t++] = i;//这样的用处是保证sum[num[i]]是单调递增的,则它都是能取到的最小的sum,所以每次能保证sum[i+1]-sum[num[头]]能得到最大的值
            while(h < t && i+1 - num[h] > k)
                h ++;//长度超过m,则头结点要后移
            if(sum[i+1] - sum[num[h]] > maxn){
                maxn = sum[i+1] - sum[num[h]];//更新maxs值和开始点结束点
                beg = num[h] + 1;
                end = i + 1;
            }
        }
        if(beg > n)
            beg -= n;
        if(end > n)
            end -= n;
        cout << maxn << " " << beg << " " << end << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值