KMP:Oulipo

Oulipo Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0


举个例子好理解,比如一个串是: a b a b a c b

那对应位置的p值为:                       0 0 1 2 3 0 0


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;

char word[10010];
char txt[1000010];
int p[10010];
int num[1000010];

int main(){
    int t;
    int i, j, k;
    scanf("%d", &t);
    while(t --){
        scanf("%s", word);
        scanf("%s", txt);
        memset(p, 0, sizeof(p));
        memset(num, 0, sizeof(num));
        int l1 = strlen(word);
        j = 0;
        for(i = 1; i < l1; i ++){
            while(j != 0 && word[i] != word[j])
                j = p[j - 1];
            if(word[i] == word[j])
                j ++;
            p[i] = j;
        }
        int l2 = strlen(txt);
        j = 0;
        for(i = 0; i < l2; i ++){
            while(j != 0 && txt[i] != word[j])
                j = p[j - 1];
            if(txt[i] == word[j])
                j ++;
            num[i] = j;
            if(j == l1)
                p[j] = p[j-1];
        }
        int ans = 0;
        for(i = 0; i < l2; i ++){
            if(num[i] == l1)
                ans ++;
        }
        for(i = 0; i < l1; i ++){
            printf("%d ", p[i]);
        }
        printf("%d\n", ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值