这是一道北大OJ上的道
题目描述
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
输入
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 20,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 2,000,000.
输出
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
样例输入
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
样例输出
1
3
0
分析:
使用KMP算法匹配字符串
#include <bits/stdc++.h>
using namespace std;
string sam,t;
int nxt[1000050];
int sl,tl;
void getnxt(){
//求next数组
int j = 0,k = -1;
nxt[0] = -1;
while(j < tl){
if(k == -1||t[j] == t[k])
nxt[++j] = ++k;
else k = nxt[k];
}
}
int kmpcount(){
//找总匹配数
int res = 0;
int i = 0;
int j = 0;
if(sl == 1&&tl == 1){
if(sam[0] == t[0])
return 1;
else return 0;
}
getnxt();
for(i = 0;i < sl;i++){
while(j>0&&sam[i]!=t[j]){
j = nxt[j];
}
if(sam[i] == t[j])
j++;
if(j == tl){
res++;
j = nxt[j];
}
}
return res;
}
int main(){
int W;
cin>>W;
for(int l = 0;l<W;l++){
cin>>t>>sam;
sl = sam.size();
tl = t.size();
cout<<kmpcount()<<endl;
}
return 0;
}