深搜:Red and Black

Red and Black

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 17
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
PKU



#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#define Max 52

using namespace std;

int data[Max][Max];
int vis[Max][Max];
int a,b,count=0;
int sum=0,tmp=0;
struct mod{
    int e,w,n,s;
}pas[Max][Max];
void sign(){
	int i,j;
    for(i=1;i<=a;i++)
		for(j=1;j<=b;j++){
		    if(!(data[i][j]&1))
				pas[i][j].w=1;
			if(!(data[i][j]&4))
				pas[i][j].e=1;
			if(!(data[i][j]&2))
				pas[i][j].n=1;
			if(!(data[i][j]&8))
				pas[i][j].s=1;
		}
}
void dfs(int x,int y){
    if(!x||!y||x==a+1||y==b+1||vis[x][y])
		return ;
	//int der[4][2] = {{0,1},{0,-1},{-1,0},{1,0}};
    vis[x][y]=1;
	tmp++;
	if(pas[x][y].w)
		dfs(x,y-1);
	if(pas[x][y].e)
		dfs(x,y+1);
	if(pas[x][y].n)
		dfs(x-1,y);
	if(pas[x][y].s)
		dfs(x+1,y);
}
int main(){
	int i,j;
    cin>>a>>b;
	for(i=1;i<=a;i++)
		for(j=1;j<=b;j++)
			scanf("%d",&data[i][j]);
	sign();
    for(i=1;i<=a;i++)
		for(j=1;j<=b;j++){
			//printf("aa");
		    if(vis[i][j])
				continue;
			//printf("bb");
			count++;
			dfs(i,j);
			if(tmp>sum)
				sum=tmp;
			tmp=0;
		}
	cout<<count<<endl<<sum<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值