hdu 3635 Dragon Balls 【基础带权并查集】

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3461    Accepted Submission(s): 1348


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
  
  
2 3 3
T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
  
  
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 分析:此题很明显是带权并查集裸体,值得注意的一点是如果城市A的龙珠被带到城市B,则从此不会有其它城市龙珠被带到城市A
  
  • #include<stdio.h>
  • #include<string.h>
  • #include<algorithm>
  • #include<iostream>
  • #define maxh 10000+10
  • using namespace std;
  • int set[maxh],move[maxh],rank[maxh];
  • void init(int n)
  • {
  •     for(int i=0;i<=n;i++)
  •     {
  •         set[i]=i,move[i]=0,rank[i]=1;
  •     }
  • }
  • int findx(int x)
  • {   
  •     if(x==set[x])
  •     {
  •         return x;   
  •     }
  •     else
  •     {
  •        int p=set[x];
  •        set[x]=findx(set[x]);
  •        move[x]+=move[p];
  •     }
  •     return set[x];
  • }
  • void fun(int x,int y)
  • {   
  •     x=findx(x);
  •     y=findx(y);
  •     if(x!=y)
  •     {
  •       set[x]=y;
  •       move[x]++;
  •       rank[y]+=rank[x];
  •       rank[x]=0;
  •     }
  • }
  • int main()
  • {
  •     char c[3];
  •     int T,a,b,n,m,temp;
  •     scanf("%d",&T);
  •     for(int t=1;t<=T;t++)
  •     {   
  •         scanf("%d%d",&n,&m);
  •         init(n);
  •         printf("Case %d:\n",t);
  •         for(int i=0;i<m;i++)
  •         {   
  •             scanf("%s",c);
  •             if(c[0]=='T')
  •             {
  •                 scanf("%d%d",&a,&b);
  •                 fun(a,b);
  •             }
  •             else
  •             {
  •                 scanf("%d",&a);
  •                 temp=findx(a);
  •                 printf("%d %d %d\n",temp,rank[temp],move[a]);
  •             }
  •         }
  •     }
  •     return 0;
  • }
  •     
  •     
  •     

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值