POJ——1502 MPI Maelstrom (Dijkstra)

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

 

题意: 一看这个题,大家应该第一感觉是,卧操!阅读理解吗???!!,它的意思就是说,从第一个的位置走到所有位置所用的时间。

题解: 因为是处理器,所以向(能走的)各个地方走的时候是同时进行的,所以不能简单的找出到各个位置的最短时间加和,要找出到各个位置的最短时间的最大值,就可以了(因为是同时进行);

给的样例是这个意思:

0        50       30       100       10

50      0         5         20          x

30      5         0         50          x

100    20       50       0            10

10      x         x          10          0 

主对角线全是0,样例给出的是一半,因为从i——>jj——>i所用时间一样。

下面看一下代码吧:

 

#include <iostream>
#include <cstring>
#include <cstdlib>
using namespace std;
const int MAX=200;
const int inf=0x3f3f3f3f;//表示一个大数
int mp[MAX][MAX],dis[MAX],vis[MAX];
int n;
void Dijkstra(){// 算法模板
	memset(vis,0,sizeof(vis));//初始化
	memset(dis,inf,sizeof(dis));//初始化
	dis[1]=0;//算法开始第一个点的值设为0
	for (int i = 1; i <= n;i++){
		int k=-1;
		int minn=inf;
		for (int j = 1; j <= n;j++){// 每次找最小的点
			if(!vis[j]&&dis[j]<minn){//判断点是否用过,以及找最小值的点
				k=j;
				minn=dis[j];
			}
		}
		vis[k]=1;// 用过的点就不用了
		for (int r = 1; r <= n;r++){// 更新相邻点的值
			if(!vis[r]&&dis[r]>dis[k]+mp[k][r]){
				dis[r]=dis[k]+mp[k][r];
			}
		}
	}
}
int main(){	
    cin >> n;
    memset(mp,inf,sizeof(mp));//初始化
    for (int i = 1; i <= n;i++){
    	mp[i][i]=0;
	}//对角线的值为0,其余设为无穷大。
	for (int i = 2; i <= n;i++){
		for (int j = 1; j < i;j++){// 输入
		    char ch[10];
			cin >> ch;
			if(ch[0]!='x'){
				mp[i][j]=mp[j][i]=atoi(ch);//把字符串转化为数字,用到atoi函数,头文件为#include <cstdlib>,只能为char类型的字符串
			}
			/*if(ch!="x"){
				mp[i][j]=mp[j][i]=atoi(ch);// 这样写不对,我很迷!!
			}*/
		}
	}
	Dijkstra();
	int ans=-1;
	for(int i = 1;i <= n;i++){//应该从i=1开始比较
		if(dis[i]>ans) ans=dis[i];//找,到所有点的最短路中,最大的数
	}	
    /*for(int i = 2;i <= n;i++){// 从i=2开始也能过,我很迷,因为如果输入1的话是输出0,我的程序输出是-1,也能过,醉了!!!
		if(dis[i]>ans) ans=dis[i];//找,到所有点的最短路中,最大的数
	}*/
	cout << ans << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

心脏dance

如果解决了您的疑惑,谢谢打赏呦

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值