HDU——1712 ACboy needs your help(分组背包)

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit? 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. 
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. 
N = 0 and M = 0 ends the input. 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain. 

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

3
4
6

题意:有n个课程,每个课程用不同的时间学习能得到不同的收获。求m天能得到的最大收获。给出的是矩阵形式,比如说第一个样例,是2行2列的矩阵,第一行为第一个课程,学习不同天的收获,第一行第一列那个数为学习第一个课程一天的收获,第二行第二列的那个数为学习第一个课程二天的收获,第二行为第二个课程,收获是多少——(同第一行的解释),这样应该懂了吧,不懂留言哦~

题解:抽象一下,背包容量相当于拥有的时间,然后给你若干组物品(课程),每一组物品里面有着若干个物品(课程时间),一组里面的物品只能选择一个,这么一抽象,标准的分组背包问题,模板题~~~详细见代码:

 

#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 200;
int a[MAX][MAX],dp[MAX];
int main(){
	int n,m;
	while(cin >> n >> m,n+m){
		memset(dp,0,sizeof(dp));
		for (int i = 1; i <= n;i++){
			for (int j = 1; j <= m;j++){
				cin >> a[i][j];
			}
		}
		for (int i = 1; i <= n;i++){
			for (int j = m; j >= 0;j--){//容量循环
				for (int k = 1; k <= m;k++){//个数循环
					if(j-k>=0) dp[j]=max(dp[j],dp[j-k]+a[i][k]);//j-k判断,防止数组越界
				}
			}
		}
		cout << dp[m] << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

心脏dance

如果解决了您的疑惑,谢谢打赏呦

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值