HDU-1712 ACBoy needs your help (分组背包问题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1712

题目:

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5653    Accepted Submission(s): 3077


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
  
  
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
  
  
3 4 6
 

这道题目是背包问题中最基础的分组背包,分组背包的基本题意就是有一个容量为v的背包,现在有k组物品,每组物品有a[k]件,每件物品容量为c[i],价值为d[i],现在每组物品中最多只能取一个,问不超过背包容量的前提下能装物品的最大价值是多少。

这种题目的做法依旧是建立在01背包的基础上,只是最外层的每一件物品的遍历换成了组数的遍历,因为我们一组最多取一个或者不取,然后在最内层加上对这一层内所有物品的遍历,理解一下也是不是很难,这样遍历下来的结果就是最优解。

#include<iostream>
#include<algorithm>
#include<math.h>
#include<cstring>
#define maxn 105
using namespace std;
int dp[maxn],profit[maxn];
int	main(){
	int m,n;
	while(cin>>n>>m){
		if(m==0 && n==0) break;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++){                        //遍历组数
			for(int j=1;j<=m;j++)                 //输入数据
				cin>>profit[j];
			for(int j=m;j>=0;j--)                 //01背包内层循环
				for(int k=1;k<=m;k++)         //附加的循环
					if(j>=k)
					dp[j]=max(dp[j],dp[j-k]+profit[k]);
		}
		cout<<dp[m]<<endl;
	}
	return 0;
}


好好学习,天天向上。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值