hdu__Lowest bit1196 (二进制的低位输出)

给你一个正整数A(1<A<100),输出它的最低位。

例如,给你一个A=26,我们可以把A写成二进制形式11010,因此,最低位是10,所以输出的应该是2;又如A=88,写成二进制为1011000,

最低位为1000,所以输出8

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
 
Output
For each A in the input, output a line containing only its lowest bit.
Sample Input
  
  
26 88 0
 
Sample Output
  
  
2 8

 

#include<stdio.h>
int main()
{
    int n,s,t;
    while(scanf("%d",&n)&&(n!=0))
    {
      s=1;
      while(n>0)
      {
          t=n%2;
          if(t==1) break;
          s=s*2;
          n/=2;
      }
      printf("%d\n",s);
    }
    return 0;
}

 

最简代码

# include <stdio.h>
int main()
{
 int n;
 while(scanf("%d",&n)!=EOF&&n)
  printf("%d\n",n&(-n));
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值