hdu1062decimal system



   本题的大意就是把一组Y进制的数中的每一个数都转化为十进制的数,然后再求这组数的和。我用的就是基本的方法,代码不是很完美,有个地方给警告了,但是用C++提交就AC了。

                                                    decimal system

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3386    Accepted Submission(s): 1922


Problem Description
As we know , we always use the decimal system in our common life, even using the computer. If we want to calculate the value that 3 plus 9, we just import 3 and 9.after calculation of computer, we will get the result of 12.
But after learning <<The Principle Of Computer>>,we know that the computer will do the calculation as the following steps:
1 computer change the 3 into binary formality like 11;
2 computer change the 9 into binary formality like 1001;
3 computer plus the two number and get the result 1100;
4 computer change the result into decimal formality like 12;
5 computer export the result;

In the computer system there are other formalities to deal with the number such as hexadecimal. Now I will give several number with a kind of change method, for example, if I give you 1011(2), it means 1011 is a number in the binary system, and 123(10) means 123 if a number in the decimal system. Now I will give you some numbers with any kind of system, you guys should tell me the sum of the number in the decimal system.
 
Input
There will be several cases. The first line of each case contains one integers N, and N means there will be N numbers to import, then there will be N numbers at the next N lines, each line contains a number with such form : X1….Xn.(Y), and 0<=Xi<Y, 1<Y<=10. I promise you that the sum will not exceed the 100000000, and there will be at most 100 cases and the 0<N<=1000.
 
Output
There is only one line output case for each input case, which is the sum of all the number. The sum must be expressed using the decimal system.
 
Sample Input
  
  
3 1(2) 2(3) 3(4) 4 11(10) 11(2) 11(3) 11(4)
 
Sample Output
  
  
6 23
#include<stdio.h>
#include<math.h>
int main()
{
    int a[1005],n,x,y,i,sum;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;
        while(n--){
        scanf("%d(%d)",&x,&y);
        i=0;
        while(x)
        {
            a[i]=(x%10)*pow(y, i);//如果不用pow就是位运算 
            x=x/10;
            sum+=a[i];
            if(x==0) break;
            else i++;
        }
    	}
        printf("%d\n",sum);
    }
    return 0;
}

//提交要用  c++ !!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值