hdu1563Find your present



     这道题就是找出来独特的数。举个例子,给出一组数,若一个数出现的次数只有一次,而其它数都出现两次,那么这个数就是你要找的数啦。先排个序,然后把它输出就行了。

刚开始看到题的时候我就没想起来能用排序来实现,看了别人的代码突然觉得这么整挺简单的。借鉴了别人的思路,编了个简单易懂的代码。

Find your present!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2691    Accepted Submission(s): 1786


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
  
  
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
  
  
3 2
ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
    int n,a[205],i;
    while(scanf("%d",&n)&&n!=0)
    {
         memset(a,0,sizeof(a));
         for(i=0;i<n;i++)
           scanf("%d",&a[i]);
         sort(a,a+n);
         for(i=0;i<n;i++)  //不能漏掉这个 for语句,前边的 for语句对下边的 if语句不起作用 
            if(a[i]!=a[i-1]&&a[i]!=a[i+1])
            printf("%d\n",a[i]); 
    }
    //while(1);
    return 0;
}
//简单易懂,

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值