母函数之Big Event in HDU hdoj 1171

110 篇文章 0 订阅
10 篇文章 0 订阅


Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23346    Accepted Submission(s): 8219


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
 

Sample Output
20 10
40 40
 

Author
lcy
 

Recommend
We have carefully selected several similar problems for you:  1203 2159 2955 2844 1087

方法1:

  利用母函数解题;此题可以完全套用《选课时间(题目已修改,注意读题)》(hdoj 2079)题;
#include<cstdio>
#include<string.h>
#include<stdlib.h>
#define M 250001
int c1[M];
int c2[M];
int v[51];
int m[51];

int main()
{
 int n;
 while(scanf("%d",&n)&&(n>=0)) //注意此处不是n!=-1结束,否则永远超时;
    {
     int i,j,k,s,t,p=0;
     memset(v,0,sizeof(v));
     memset(m,0,sizeof(m));
     
     for(i=1,s=0;i<=n;i++)
     {
      scanf("%d%d",&v[i],&m[i]);
       s+=v[i]*m[i];
     }
   
        memset(c1,0,sizeof(c1));
        memset(c2,0,sizeof(c2));
       
    //for(i=0;i<=s/2;i++)
           //c1[i]=1;
          
  c1[0]=1;
       for(i=0;i<=v[1]*m[1];i+=v[1])
        c1[i]=1;
    
        for(i=2;i<=n;i++)
        {
         for(j=0;j<=s/2;j++)
           for(k=0,p=0;p<=m[i]&&k+j<=s/2;k+=v[i],p++)
              c2[j+k]+=c1[j];
             
              for(j=0;j<=s/2;j++)
                {
                 c1[j]=c2[j];
                 c2[j]=0;
                }
        }
       
        for(i=s/2;i>=0;i--)
         if(c1[i]!=0)
            {
      printf("%d %d\n",s-i,i);
      break;
            }
 }
 return 0;
}
方法2:

   先算总经费sum1,并且将每一个V存到一个数组a[]中,再将该数组排序,再将这个数组的所有元素按照从大到小的顺序累加直到找到一个值sum+a[i]使得它的值大于sum1/2;此时的sum就是B,sum1-sum就是A;

#include<cstdio>
#include<string.h>
#include<stdlib.h>
#define M 110000
int a[M];
int cmp(const void*a,const void*b)
{
 return *(int*)a-*(int*)b;
}
int main()
{
 int n;
 while(scanf("%d",&n)&&(n>=0))
 {
  int i,sum1,half,sum;
  int v,m;
  memset(a,0,sizeof(a));
  
  int k=0;
  for(i=0,sum1=0;i<n;i++)
  {
   scanf("%d%d",&v,&m);
   sum1+=v*m;
   while(m--)
             a[k++]=v;
  }
  half=sum1/2;
  
   qsort(a,0,sizeof(a[0]),cmp);
  
   for(i=k-1,sum=0;i>=0;i--)
   { 
  
    if(sum+a[i]>half)
      continue;
    sum+=a[i];
   }
   printf("%d %d\n",sum1-sum,sum);
 }
 return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值