hdoj problem 5018 Revenge of Fibonacci(杂码&&菲菠数列)

Revenge of Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 726    Accepted Submission(s): 336


Problem Description
In mathematical terms, the sequence Fn of Fibonacci numbers is defined by the recurrence relation
Fn = Fn-1 + Fn-2
with seed values F1 = 1; F2 = 1 (sequence A000045 in OEIS).
---Wikipedia

Today, Fibonacci takes revenge on you. Now the first two elements of Fibonacci sequence has been redefined as A and B. You have to check if C is in the new Fibonacci sequence.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers A, B and C.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= A, B, C <= 1 000 000 000
 

Output
For each test case, output “Yes” if C is in the new Fibonacci sequence, otherwise “No”.
 

Sample Input
  
  
3 2 3 5 2 3 6 2 2 110
 

Sample Output
  
  
Yes No Yes
Hint
For the third test case, the new Fibonacci sequence is: 2, 2, 4, 6, 10, 16, 26, 42, 68, 110…
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:  5099 5098 5097 5096 5095 
/*本人AC*/
#include<cstdio>
#include<cstring>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define M 1000000000
double f[100000]; 
int main()
{
   int n;
  scanf("%d",&n);
  while(n--)
  {
      __int64 a,b,c;
      scanf("%I64d%I64d%I64d",&a,&b,&c);
     int i,flag=0;
     f[1]=a;
     f[2]=b;
     if(c==b||a==c)//注意这人有个坑,月赛中我被坑的好苦啊~~~~~~~~~~~~~~~~~~
      //这里不要用flag来标记,因为后面的操作会直接将flag的值覆盖,我就是错在这儿
       {
        printf("Yes\n");
       }
      else
      {
     
      
          for(i=3;;i++)
          {
              f[i]=f[i-1]+f[i-2];
              if(f[i]==c)
                {
                    flag=1;
                    break;
                }
                else if(f[i]>c)
                  break;
          }
         if(flag)
           printf("Yes\n");
          else
           printf("No\n");
   }
  }
  return 0;
}

/*他人AC*/
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
    int n,i,a,b,c,k;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d%d",&a,&b,&c);
        if(c==a||c==b)
            printf("Yes\n");
        else
        {
            for(;;)
            {
                k=a+b;
                if(k>=c)
                {
                    if(k==c)
                        printf("Yes\n");
                    else
                        printf("No\n");
                    break;
                }
                a=b;b=k;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值