hdoj problem 1016 Prime Ring Problem(素数环&&素数问题+DFS(回溯法))

110 篇文章 0 订阅
6 篇文章 0 订阅

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27985    Accepted Submission(s): 12445


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1010 1241 1312 1072 1242 

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define M 22
int isprime[M];//判断素数的标记数组
int vis[M];//遍历过程中的标记数组
int a[M];//存储数组

void dfs(int n,int cur,int *a)
{
    int i;
if(cur==n&&!isprime
[a[0]+a[n-1]])//递归边界。别忘了测试第一个数和最后一个数
{
 printf("%d",a[0]);
 for(i=1;i<n;i++)
    printf(" %d",a[i]);
printf("\n");
}
else
 for(i=2;i<=n;i++)//尝试放每一个数i
    if(!vis[i]&&!isprime[i+a[cur-1]])//如果i没用过,并且与前一个数之和为素数
    {
    a[cur]=i;//用数组将处理判断过的数组存起来
    vis[i]=1;//设置使用标志
    dfs(n,cur+1,a);
    vis[i]=0;//清除标志
}
}

int main()
{
   int n,ca=1,i=0,j=0;
memset(isprime ,0,sizeof(isprime));
isprime[0]=isprime[1]=1;//素数打表法判断素数
for(i=2;i*i<M;i++)
  if(!isprime[i])
  for(j=i*i;j<=M;j+=i)
     isprime[j]=1;  
  
   while(~scanf("%d",&n)) 
   {   
   memset(vis,0,sizeof(vis));
   memset(a,0,sizeof(a));
 
  a[0]=1; 

printf("Case %d:\n",ca++);
    dfs(n,1,a);
    printf("\n");
   }
return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值