POJ 3006 Dirichlet's Theorem on Arithmetic Progressions(我的水题之路——加i个d后的第几个素数)

博客介绍了Dirichlet定理,即互质正整数a和d构成的算术序列包含无穷多个素数。任务是编写程序找出给定a、d和n的算术序列中的第n个素数,输入条件保证结果小于100万。
摘要由CSDN通过智能技术生成
Dirichlet's Theorem on Arithmetic Progressions
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11068 Accepted: 5539

Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da + 3da + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346, and n <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673

Source


给三个数a, d, n,问,对a,加上i个d(i=0,1, 2, 3,4...)得到的这些数字中,第n个素数是多少?

筛法打素数表,然后暴力得到这些数字,判断是否为素数,若是则次数times+1,直到得到第n个素数。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

#define N 1000000

int prime[N];

void init(){
    int i, j, k;

    for (i = 0; i < N; i++){
        prime[i] = 1;
    }
    prime[0] = 0;
    prime[1] = 0;
    for (i = 0; i < N; i++){
        if (prime[i] != 0){
            for (j = i + i; j < N; j += i){
                prime[j] = 0;
            }
        }
    }
}

int main(void){
    int a, d, n;
    int times, i, tmp;

    init();
    while (scanf("%d%d%d", &a, &d, &n), a != 0 || d != 0 || n != 0){
        times = 0;
        for (i = a; i < 1000000 && times != n; i += d){
            if (prime[i] != 0){
                times++;
                tmp = i;
            }
        }
        printf("%d\n", tmp);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值