hdoj 1423 Greatest Common Increasing Subsequence(最长上升公共子序列)

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4801    Accepted Submission(s): 1529


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2
 

Source
 
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
#define Inf 0x7fffffff
const int MAX=501;
int a[MAX];
int b[MAX];
int dp[MAX];

int main()
{
	int  T;
	scanf("%d",&T);
	while(T--)
	{
	  int n,m,i,j;
	  scanf("%d",&n);
	  for(i=1;i<=n;i++)
	   scanf("%d",&a[i]);
	   
	   scanf("%d",&m);
	   for(i=1;i<=m;i++)
	     scanf("%d",&b[i]);
	     
	     memset(dp,0,sizeof(dp));
	     for(i=1;i<=n;i++)
	     {
	     	 int pos=1;
			 for(j=1;j<=m;j++)
			 {
			  /// 遍历b的同时,找出 j 之前最大的公共子序列所在点 pos,并且要使 b[pos] < a[i]  
                          /// 这样,当下一句 b[j]==a[i] 时,就可以直接得到 j 点的最大公共子序列了:dp[pos]+1 
                            if(b[j]<a[i]&&dp[j]+1>dp[pos])
			       pos=j;
			    if(b[j]==a[i]&&dp[j]<dp[pos]+1)
			      dp[j]=dp[pos]+1;
          		 }  
		 }
		 
		 int ans=-Inf;
		 for(i=1;i<=m;i++)
		   if(ans<dp[i])
		    ans=dp[i];
		
		printf("%d\n",ans);
		if(T) printf("\n");
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值