杭电1423(Greatest Common Increasing Subsequence)

9 篇文章 0 订阅
8 篇文章 0 订阅

点击打开杭电1423

Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2


题意:求最长公共递增子序列的长度,直接要用模板即可( 最长递增公共子序列


代码实现:

import java.util.Scanner;


class P1423 {
	static int[] a,b,dp;
	static int n,m;
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int t=sc.nextInt();
		while(t-->0){
			n=sc.nextInt();
			a=new int[n+1];
			for(int i=1;i<=n;i++){
				a[i]=sc.nextInt();
			}
			m=sc.nextInt();
			b=new int[m+1];
			for(int i=1;i<=m;i++){
				b[i]=sc.nextInt();
			}
			System.out.println(LICS());
			if(t!=0){
				System.out.println();
			}
		}
	}
	public static int LICS() {
		int i,j,Max;
		int lengMax=Math.max(n, m);
		dp=new int[lengMax+1];
		for(i=1;i<=n;i++){
			Max=0;
			for(j=1;j<=m;j++){
				if(a[i]>b[j] && Max<dp[j]){
					Max=dp[j];
				}
				if(a[i]==b[j]){
					dp[j]=Max+1;
				}
			}
		}
		Max=0;
		for(i=1;i<=m;i++){
			if(Max<dp[i]){
				Max=dp[i];
			}
		}
		return Max;
	}
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值