poj 3278 Catch That Cow(BFS)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 61200 Accepted: 19106

点击打开链接

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题意:
  农夫抓牛:农夫在N点 (0 ≤  N  ≤ 100,000),牛在K点 (0 ≤  N  ≤ 100,000),其中农夫抓牛过程中的方式有:
  1.步行:从当前点X到X-1或者X+1;
  2.远程:从当前点X到2*X点;
求农夫找到牛的最少步数
题意分析:
  本题是一个广搜,利用队列 ,注意边界
代码:
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<queue>
using namespace std;
#define MAX 100005
queue<int>q;

int step[MAX];
int vis[MAX];

int BFS(int st,int ed)
{
  while(!q.empty())
  q.pop();
  
  q.push(st);
  vis[st]=1;
  
  int temp=0;
  while(!q.empty())
  {
  	int x=q.front();
  	q.pop();
  	
  	for(int i=0;i<3;i++)
	{
	  if(i==0)//向前走
	  	temp=x+1;
	  else if(i==1)//向后走
	    temp=x-1;
	  else if(i==2)//跳着走
	    temp=x*2;
	  
	  if(temp>=0&&temp<=MAX-5&&!vis[temp])//注意边界,并且是没有被访问的点
	  {
	    step[temp]=step[x]+1;//此处当注意
	  	if(temp==ed)//边界
	  	return step[temp];
	  	vis[temp]=1;
	  	q.push(temp);
	  }
	} 
  }
}

int main()
{
	int N,K;
   while(~scanf("%d%d",&N,&K))
   {
   	memset(vis,0,sizeof(vis));
   	memset(step,0,sizeof(step));
	if(N>=K)//注意
   	printf("%d\n",N-K);
   	else
   	printf("%d\n",BFS(N,K));
   }
  return 0;	
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值