Zoj 1671 Walking Ant(BFS+优先队列||记忆化搜索)

5 篇文章 0 订阅
2 篇文章 0 订阅

Walking Ant

Time Limit: 2 Seconds Memory Limit: 65536 KB
点击打开链接

Ants are quite diligent. They sometimes build their nests beneath flagstones.

Here, an ant is walking in a rectangular area tiled with square flagstones, seeking the only hole leading to her nest.

The ant takes exactly one second to move from one flagstone to another. That is, if the ant is on the flagstone with coordinates (x,y) at time t, she will be on one of the five flagstones with the following coordinates at time t+1:

(x, y), (x+1, y), (x-1, y), (x, y+1), (x, y-1).

The ant cannot go out of the rectangular area. The ant can visit the same flagstone more than once.

Insects are easy to starve. The ant has to go back to her nest without starving. Physical strength of the ant is expressed by the unit "HP". Initially, the ant has the strength of 6 HP. Every second, she loses 1 HP. When the ant arrives at a flagstone with some food on it, she eats a small piece of the food there, and recovers her strength to the maximum value, i.e., 6 HP, without taking any time. The food is plenty enough, and she can eat it as many times as she wants.

When the ant's strength gets down to 0 HP, she dies and will not move anymore. If the ant's strength gets down to 0 HP at the moment she moves to a flagstone, she does not effectively reach the flagstone: even if some food is on it, she cannot eat it; even if the hole is on that stone, she has to die at the entrance of her home.

If there is a puddle on a flagstone, the ant cannot move there.

Your job is to write a program which computes the minimum possible time for the ant to reach the hole with positive strength from her start position, if ever possible.


Input

The input consists of multiple maps, each representing the size and the arrangement of the rectangular area. A map is given in the following format.

w h
d11 d12 d13 ... d1w
d21 d22 d23 ... d2w
...
dh1 dh2 dh3 ... dhw

The integers w and h are the numbers of flagstones in the x- and y-directions, respectively. w and h are less than or equal to 8. The integer dyx represents the state of the flagstone with coordinates (x, y) as follows.

0: There is a puddle on the flagstone, and the ant cannot move there.
1, 2: Nothing exists on the flagstone, and the ant can move there. `2' indicates where the ant initially stands.
3: The hole to the nest is on the flagstone.
4: Some food is on the flagstone.

There is one and only one flagstone with a hole. Not more than five flagstones have food on them.

The end of the input is indicated by a line with two zeros.

Integer numbers in an input line are separated by at least one space character.


Output

For each map in the input, your program should output one line containing one integer representing the minimum time. If the ant cannot return to her nest, your program should output -1 instead of the minimum time.


Sample Input

3 3
2 1 1
1 1 0
1 1 3
8 4
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
8 5
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1
8 7
1 2 1 1 1 1 1 1
1 1 1 1 1 1 1 4
1 1 1 1 1 1 1 1
1 1 1 1 4 1 1 1
4 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 3
8 8
1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1
1 4 4 1 1 1 1 1
1 4 4 2 1 1 0 0
1 1 0 0 0 0 0 3
1 1 0 4 1 1 1 1
1 1 1 1 1 1 1 1
8 8
1 1 1 1 1 1 1 1
1 1 2 1 1 1 1 1
1 1 4 4 4 1 1 1
1 1 1 4 4 1 0 1
1 1 1 1 1 1 0 1
1 1 1 1 1 1 0 3
1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1
0 0


Sample Output

4
-1
13
20
-1
-1


Source: Asia 1999, Kyoto (Japan)
题意:

       2为起点,3为终点,1为空地,4为食物,0为水池不可通过,蚂蚁起始的HP为6,每走一步HP减少1,如果蚂蚁

        可以吃到食物则HP恢复为6(到达食物所在地时最少HP要求为1)问蚂蚁需要几步可以从起点走到终点

题目分析:

      一开始我以为是普通搜索,后来才知道需要记忆化搜索,否则就出不来。既然记忆化搜索,那么你就不能随便的标记了,注意边界,注意题目给的条件


#include<cstdio>
#include<cstring>
#include<queue> 
#include<cstdlib>
#include<algorithm>
using namespace std;
int w,h,sx,sy,ex,ey;
int map[8][8];
int dp[8][8];
int fx[4]={1,0,-1,0};
int fy[4]={0,1,0,-1};

struct node
{
  int x,y;
  int hp;
  int step;
};

void input()
{
	for(int i=0;i<h;i++)//注意行和列,一不小心就错了
 	 for(int j=0;j<w;j++)
 	 {
 	   scanf("%d",&map[i][j]);
		if(map[i][j]==2)
		{
		 sx=i;
		 sy=j;	
		}
		if(map[i][j]==3)
		{
		 ex=i;
		 ey=j;	
		}
		dp[i][j]=0;	
	 }
}

int valid(node p)
{
  if(p.x>=0&&p.x<h&&p.y>=0&&p.y<w)
   return 1;
   else
   return 0;	
}

queue<node>q;
void BFS()
{
  node p1,p2;
  p1.x=sx;
  p1.y=sy;
  p1.hp=6;
  p1.step=0;
  
  dp[sx][sy]=6;//注意这儿
  
  while(!q.empty())
   q.pop();
   
   q.push(p1);
   while(!q.empty())
   {
   	 p1=q.front();
   	 q.pop();
   	 
   	 if(p1.x==ex&&p1.y==ey&&p1.hp>0)
   	 {
   	  printf("%d\n",p1.step);
	  return ;	
	 }
	   if(p1.hp==1)
	    continue ;
	 	for(int i=0;i<4;i++)
	 	{
	 	  p2.x=p1.x+fx[i];
		  p2.y=p1.y+fy[i];
		  if(map[p2.x][p2.y]&&valid(p2)&&dp[p2.x][p2.y]<dp[p1.x][p1.y])
		  {
			p2.step=p1.step+1;
			if(p2.x==ex&&p2.y==ey)
			{
				printf("%d\n",p2.step);
				return ;
			}
			if(map[p2.x][p2.y]==4)//食物杯吃后应该是能走的路
			{
				 dp[p2.x][p2.y]=6; 
				 map[p2.x][p2.y]=1;
			}
			else
			dp[p2.x][p2.y]=dp[p1.x][p1.y]-1;
		        p2.hp=dp[p2.x][p2.y];
		  	q.push(p2);
		  }
		}
   }
   printf("-1\n");
}


int main()
{
 while(scanf("%d%d",&w,&h),(w||h))
 {
   input();
   BFS();
 } 
 return 0;	
} 

看到人家的另外一种思路:

   直接用优先队列就OK了

代码:

#include<cstdio>
#include<cstring>
#include<queue> 
#include<cstdlib>
#include<algorithm>
using namespace std;
int w,h,sx,sy,ex,ey;
int map[8][8];
int fx[4]={1,0,-1,0};
int fy[4]={0,1,0,-1};

struct node
{
  int x,y;
  int hp;
  int step;
  friend bool operator< (node a,node b)
  {
  	return a.step>b.step;
  }
};

void input()
{
	for(int i=0;i<h;i++)
 	 for(int j=0;j<w;j++)
 	 {
 	   scanf("%d",&map[i][j]);
		if(map[i][j]==2)
		{
		 sx=i;
		 sy=j;	
		}
		if(map[i][j]==3)
		{
		 ex=i;
		 ey=j;	
		}	
	 }
}

int valid(node p)
{
  if(p.x>=0&&p.x<h&&p.y>=0&&p.y<w)
   return 1;
   else
   return 0;	
}

priority_queue<node>q;
void BFS()
{
  node p1,p2;
  p1.x=sx;
  p1.y=sy;
  p1.hp=6;
  p1.step=0;
  
  while(!q.empty())
   q.pop();

   q.push(p1);
   while(!q.empty())
   {
   	 p1=q.top();
   	 q.pop();
   	 
   	 if(p1.x==ex&&p1.y==ey&&p1.hp>0)
   	 {
   	  printf("%d\n",p1.step);
	  return ;	
	 }
	  if(p1.hp==1)
	   continue ;
	 	for(int i=0;i<4;i++)
	 	{
	 	  p2.x=p1.x+fx[i];
		  p2.y=p1.y+fy[i];
		  if(map[p2.x][p2.y]&&valid(p2))
		  {
			p2.step=p1.step+1;
			if(p2.x==ex&&p2.y==ey)
			{
				printf("%d\n",p2.step);
				return ;
			}
			if(map[p2.x][p2.y]==4)
			{
				 p2.hp=6; 
				 map[p2.x][p2.y]=1;
			}
			else
			p2.hp=p1.hp-1;
		
		  	q.push(p2);
		  }
		}
   }
   printf("-1\n");
}

int main()
{
 while(scanf("%d%d",&w,&h),(w||h))
 {
   input();
   BFS();
 } 
 return 0;	
} 





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值