HDU 3486 Interviewe(RMQ+枚举)

OJ链接

Description

YaoYao has a company and he wants to employ m people recently. Since his company is so famous, there are n people coming for the interview. However, YaoYao is so busy that he has no time to interview them by himself. So he decides to select exact m interviewers for this task.
YaoYao decides to make the interview as follows. First he queues the interviewees according to their coming order. Then he cuts the queue into m segments. The length of each segment is , which means he ignores the rest interviewees (poor guys because they comes late). Then, each segment is assigned to an interviewer and the interviewer chooses the best one from them as the employee.
YaoYao’s idea seems to be wonderful, but he meets another problem. He values the ability of the ith arrived interviewee as a number from 0 to 1000. Of course, the better one is, the higher ability value one has. He wants his employees good enough, so the sum of the ability values of his employees must exceed his target k (exceed means strictly large than). On the other hand, he wants to employ as less people as possible because of the high salary nowadays. Could you help him to find the smallest m?

Input

The input consists of multiple cases.
In the first line of each case, there are two numbers n and k, indicating the number of the original people and the sum of the ability values of employees YaoYao wants to hire (n≤200000, k≤1000000000). In the second line, there are n numbers v1, v2, …, vn (each number is between 0 and 1000), indicating the ability value of each arrived interviewee respectively.
The input ends up with two negative numbers, which should not be processed as a case.

Output

For each test case, print only one number indicating the smallest m you can find. If you can’t find any, output -1 instead.

Sample Input

11 300
7 100 7 101 100 100 9 100 100 110 110
-1 -1

Sample Output

3

题意

有n个人排队应聘,每个人的能力值为v,老板要把这些人分成m段。如果不能整除多出来,就不要后面的人。然后从这m段里面选择每段中的最大能力值加起来,看是否能够大于老板需要的目标k。

思路

RMQ+枚举

AC 代码

#include <bits/stdc++.h>
#define Max 200005
using namespace std;
int n;
int a[Max];
int d[Max][20];

void st()
{
    for(int j=1;(1<<j)<=n;j++)
    {
        for(int i=0;i+(1<<j)-1<n;i++)
        {
            d[i][j] = max(d[i][j-1],d[i+(1<<(j-1))][j-1]);
        }
    }
}
int RMQ(int l,int r)
{
    int k=0;
    while((1<<(k+1))<=r-l+1)
    {
        k++;
    }
    return max(d[l][k],d[r-(1<<k)+1][k]);
}
int main()
{
    int k,i,b,len,l,r,coun,temp;
    while(scanf("%d %d",&n,&k)!=EOF && n>=0 && k>=0)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d",&b);
            a[i] = b;
            d[i][0]=a[i];
        }
        st();
        int pre=-1;
        for(i=1;i<=n;i++)
        {
            len = n/i;
            if(len!=pre)
            {
                l=0;
                r=len-1;
                if(i==1)
                {
                    r=n-1;
                }
                coun=0;
            }
            else
            {
                l=temp;
                r=temp+len-1;
            }
            while(l<i*len)
            {
                coun += RMQ(l,r);
                l+=len;
                r+=len;
            }
            if(coun>k)
            {
                break;
            }
            pre=len;
            temp=i*len;
        }
        if(i==n+1)
        {
            printf("-1\n");
        }
        else
        {
            printf("%d\n",i);
        }
    }
    return 0;
}

感想

还是得慢慢消化,毕竟这道题超时超内存运行错误答案错误全遇到,错误大满贯!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值