POJ2486 Apple Tree【树形dp】

Apple Tree

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10035Accepted: 3338

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input

Each test case contains three parts.

The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 … N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)

The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.

The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.

Input will be ended by the end of file.


Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1  
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11 
2

Source

POJ Contest,Author:magicpig@ZSU

树形做的太少,没想明白,又面向题解编程了。。。
对某个子树s,有返回和不返回两种情况,因此用多开一维,dp[s][k][0]表示从s出发搜索子树并返回s节点,一共k步,dp[s][k][1]表示不返回。
而s的状态是由其子树获得的,类似背包,步数为背包容量,子树状态为物品。
对s的子节点t,一共有三种情况,
1. 从s出发,搜索t和其他子节点并返回s
2. 从s出发,搜索其他子节点然后返回s,搜索t不返回s
3. 从s出发,搜索t然后返回s,搜索其他子节点不返回s

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#include <iostream>
using namespace std;

int n, k;
int val[110], dp[110][210][2];
vector<int> mp[110];

void dfs(int g, int p)
{
    for(int i = 0; i <= k; i++)
        dp[p][i][1] = dp[p][i][0] = val[p];
    for(vector<int>::iterator it = mp[p].begin(); it != mp[p].end(); it++)
        if(*it != g)
        {
            dfs(p, *it);
            for(int i = k; i >= 0; i--)
                for(int j = 0; j <= i; j++)
                {
                    dp[p][i+2][0] = max(dp[p][i+2][0], dp[p][i-j][0] + dp[*it][j][0]);
                    dp[p][i+1][1] = max(dp[p][i+1][1], dp[p][i-j][0] + dp[*it][j][1]);
                    dp[p][i+2][1] = max(dp[p][i+2][1], dp[p][i-j][1] + dp[*it][j][0]);
                }
        }
}
int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", val+i);
        for(int i = 1; i < n; i++)
        {
            int x, y;
            scanf("%d%d", &x, &y);
            mp[x].push_back(y);
            mp[y].push_back(x);
        }
        dfs(0, 1);
        printf("%d\n", dp[1][k][1]);

        for(int i = 1; i <= n; i++)
            mp[i].clear();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值