九度OJ 题目1001:A+B for Matrices

一.题目描述:
    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.
输入:
    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.
输出:
    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:

 2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:

1
5


二.题目分析

   简单题

三.代码

#include <stdio.h>
#include <stdlib.h>
#define MAX 11
int main()
{
    int A[MAX][MAX],B[MAX][MAX],i,j,m,n,rown,coln;

    while(scanf("%d",&m)&&m)
    {
        scanf("%d",&n);

        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
                scanf("%d",&A[i][j]);

        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
                scanf("%d",&B[i][j]);

        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
                    A[i][j] +=B[i][j];

        rown=0;
        coln=0;

        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(A[i][j])
                    break;
            }

            if(j==n)
                rown++;
        }

        for(j=0;j<n;j++)
        {
            for(i=0;i<m;i++)
            {
                if(A[i][j])
                    break;
            }
            if(i==m)
                coln++;
        }

        printf("%d\n",rown+coln);

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值