一.题目描述:
输入一个长度不超过20的字符串,对所输入的字符串,按照ASCII码的大小从小到大进行排序,请输出排序后的结果
输入:
一个字符串,其长度n<=20
输出:
输入样例可能有多组,对于每组测试样例,
按照ASCII码的大小对输入的字符串从小到大进行排序,输出排序后的结果
样例输入: dcba
样例输出: abcd
二.题目分析
水题
三.代码
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
char str[25],ch;
int i,j,len;
while(scanf("%s",str)!=EOF)
{
len=strlen(str);
for(i=0;i<len;i++)
{
for(j=i+1;j<len;j++)
{
if(str[i]>str[j])
{
ch=str[i];
str[i]=str[j];
str[j]=ch;
}
}
}
printf("%s\n",str);
}
return 0;
}