寒假训练01G:hdu1260

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input
2
2
20 25
40
1
8

Sample Output
08:00:40 am
08:00:08 am

题目大意
k个人买票,每一个人买票都花费一定的时间。每个人既可以自己单独买票,也可以和旁边的人一起买(最多两人一起买)。告诉每个人单独买票的时间和邻近的两人一起买票的时间,求这些人最短需要多久才可以都买完票。

解题思路
很明显是一个dp问题。每个人都有两种选择,所以令dp[i]为以第i个人为终点的队伍买票所需要花费的最短时间,很明显状态转移方程为dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1])(即第i个人单独买票或第i个人与前面的人一起买票所花费时间)。虽然对于每个人来说,她可以和前面的人或后面的人一起买票,但是双向考虑并不好处理。我们将这个人当成最后一人只考虑她前面的人问题会简单很多。但是这个题后面的时间处理还是挺坑的,我并不太清楚如果小时大于十二是应该直接输还是取余12以后输出,不过评判的时候这两种输出都过了,不知道是不是没有下午的数据。。。

代码

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int main()
{
    int n,k;
    int a[2005],b[2005];
    int dp[2005];
    cin>>n;
    while(n--)
    {
        cin>>k;
        for(int i=1;i<=k;i++)
        cin>>a[i];
        for(int i=1;i<k;i++)
        cin>>b[i];

        dp[0]=0;//一定要记得赋初值!!!
        dp[1]=a[1];
        for(int i=2;i<=k;i++)
        dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1]);

        int h,m,s;
        h=dp[k]/3600;
        dp[k]%=3600;
        m=dp[k]/60;
        dp[k]%=60;
        s=dp[k];

        int flag=0;
        if((8+h)>=24)
        h=(8+h)%24;
        else if((8+h)>=12)
        {   
            h=(8+h)%12;
            flag=1;
        }
        else
        h=8+h;

        printf("%02d:%02d:%02d", h, m, s);

        if(flag)
            cout<<" pm"<<endl;
        else
            cout<<" am"<<endl;

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值