poj3107:Godfather

Problem Description
Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input
The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output
Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input
6
1 2
2 3
2 5
3 4
3 6

Sample Output
2 3

题目大意
给你一棵n个结点的无向树,找到该点的重心(删除该点后,最大子树的最小)。

解题思路
树型dp里面的经典问题,可以把它当模板题了。但是这个题这样写必须要用printf和scanf写才能过啊,哭泣。。。

代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<memory.h>
using namespace std;
struct Edge
{
    int to,next;
}edge[100005];
int head[50005];
int sonsize[50005],sonmx[50005],root[50005];//子树大小,最大子树大小
int tot,num,minc;
void addedge(int u,int v)
{
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}
void dfssize(int u,int fa)//求子树大小,由叶到根遍历
{
    sonsize[u]=1;
    sonmx[u]=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].to;
        if(v==fa)
        continue;
        dfssize(v,u);
        sonsize[u]+=sonsize[v];//dp
        sonmx[u]=max(sonmx[u],sonsize[v]);
    }
}

void dfsroot(int r,int u,int fa)//求根为r的树的重心 
{
    if(sonsize[r]-sonsize[u]>sonmx[u])//u结点向上的子树 
    sonmx[u]=sonsize[r]-sonsize[u];
    if(sonmx[u]<minc)
    {
        minc=sonmx[u];
        num=0;
        root[num++]=u;
    } 
    else if(sonmx[u]==minc)
    {
        root[num++]=u;
    }
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].to;
        if(v==fa)
        continue;
        dfsroot(r,v,u);

    }
}
int main()
{
    int n,u,v;
    while(~scanf("%d",&n))
    {
        memset(head,-1,sizeof(head));
        for(int i=1;i<n;i++)
        {

            scanf("%d%d",&u,&v);
            //cin>>u>>v;
            addedge(u,v);
            addedge(v,u);
        }
        dfssize(1,-1);
        minc=1<<30;
        dfsroot(1,1,-1);
        sort(root,root+num);
        /*for(int i=0;i<num-1;i++)
        {
            cout<<root[i]<<" ";
        }
        cout<<root[num-1]<<endl;*/
        for(int i=0;i<num;i++)  
            printf("%d%c",root[i],i<num-1?' ':'\n');  
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值