dfs_1103 Integer Factorization (30 分)

目录

1103 Integer Factorization

题目描述

解题思路

程序


1103 Integer Factorization

题目描述

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

解题思路

本题中N最大为400,P最小为2,所以最多为 100 层的递归,到这里可以知道使用暴力递归求解即可

这里要求生成的序列为非递增的序列,所以在找到某位置上的数字pos后,后面递归就要从pos位置开始,这样可以避免不同顺序的序列出现多次,并且减少递归次数

当得到结果后,比较生成序列之与当前最大之和,如果大于当前最大之和,则更新序列,否则丢弃

程序

#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;
const int maxn = 405;
int n,k,p,_index,flag,maxsum = 0;
int num[25],temp[maxn],ans[maxn];
int Pow(int a,int b)
{
   int r = 1,base = a;
   while(b)
   {
       if(b % 2) r *= base;
       b >>= 1;
       base *= base;
   }
   return r;
}
void dfs(int pos,int sum, int x)
{
    if(sum == n && x == k)
    {
        int now = 0;
        for(int i = 1;i <= x;i ++) now += temp[i];
        if(now > maxsum)
        {
            for(int i = 1;i <= x;i ++) ans[i] = temp[i];
            maxsum = now;
        }
        flag = x;                                     //记录是否得到结果
        return ;
    }
    if(sum > n || x > k ||(x < k && sum == n))
        return ;

    for(int i = pos ;i >= 1;i --)                     //第一版本这里i从_index开始,这样导致生成的序列不一定是按照非递增顺序,并且处理会超时
    {                                                 //所以这里优化为由pos开始,保证序列为非递增序列,并且解决超时问题,减少不必要的递归
        temp[x+1] = i;
        dfs(i,sum+num[i],x+1);
    }
}
int main()
{
    scanf("%d%d%d",&n,&k,&p);
    _index = 1;int tmp;
    for(int i = 1;i <= n;i ++)                      //得到可能出现在序列中的数组,保存在num中
    {
        tmp = Pow(i,p);
        if(tmp <= n)
            num[_index++] = tmp;
        else
            break;
    }
    _index--;
    dfs(_index,0,0);
    if(flag == 0)
        printf("Impossible\n");
    else
    {
        printf("%d = ",n);
        for(int i = 1;i <= k;i ++)
        {
            printf("%d^%d",ans[i],p);
            if(i != k)   printf(" + ");
        }
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值