九度OJ-Beer Refrigerator

E - Beer Refrigerator
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Beer Lovers Club makes regular parties. They hate warm beer, but club’s refrigerator is too small to store enough beer for the whole company. So they decided to order a special super-big beer refrigerator. The new refrigerator should be a parallelepiped a × b × c and store exactly n cubical 1 × 1 × 1 beer boxes (the club has n members). To decrease losses of cold, the total area of the surface of the refrigerator must be as small as possible.

For example, if the capacity of the refrigerator must be 12, the possible variants are:

Dimensions Surface Area
3 × 2 × 2 32
4 × 3 × 1 38
6 × 2 × 1 40
12 × 1 × 1 50
The best variant in this case is 3 × 2 × 2.

Help the beer lovers to find the optimal dimensions of their new refrigerator.

Input
The input file contains single integer number n (1 ≤ n ≤ 106) — the capacity of the refrigerator. Help the beer lovers to find the optimal dimensions of their new refrigerator.

Output
Output three integer numbers: a, b and c — the optimal dimensions of the refrigerator. If there are several solutions, output any of them.

Sample Input

1 12

2 13

3 1000000

Sample Output

1 3 2 2

2 1 13 1

3 100 100 100

#include <stdio.h>
int main()
{
    int n;
    int factor[1000];
    int size;
    int a,b,c;
    while(scanf("%d",&n)!=EOF)
    {
        size = 0;
        int min = 100000000;
        for (int i = 1; i*i<=n; i++)
        {

            if (n%i==0)
            {
                factor[size++]=i;
                factor[size++]=n/i;
            }

        }

        //printf("%d\n",min);
        for (int i = 0; i < size; ++i)

            for (int j = 0; j < size; ++j)
            {
                if (n%(factor[i]*factor[j]))
                    continue;   
                for (int k = 0; k < size; ++k)
                {

                    if (factor[i]*factor[j]*factor[k]==n){


                        if (factor[i]*factor[j]+factor[i]*factor[k]+factor[k]*factor[j]<min)
                        {
                            min=factor[i]*factor[j]+factor[i]*factor[k]+factor[k]*factor[j];    
                            a=factor[i];
                            b=factor[j];
                            c=factor[k];

                        }


                    }
                }
            }
        printf("%d %d %d \n",a,b,c);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值