FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.
The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that
W[m[1]] < W[m[2]] < … < W[m[n]]
and
S[m[1]] > S[m[2]] > … > S[m[n]]
In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7
题目描述:
输入多只老鼠的体重和速度,要求找出最多的老鼠使得这些老鼠的体重是递增的而速度是递减的。并输出这一组老鼠的数目以及这些老鼠依次的编号。
题目分析:
- 这是一道最长最长上升子序列的题目。这道题目有两个变量,我们需要先固定其中一个,即将体重或速度进行排序。我们可以先按照体重从小到大进行排序。然后这道题就转换为了一道找最长上升子序列并记录位置的题目。
- 状态表示:
f[i][1] //为长度为i的序列所拥有的最大上升子序列的长度
f[i][2] //记录第i个元素在最长上升子序列中下一个数的位置
- 状态计算:见代码
代码如下:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <queue>
#include <algorithm>
#include <iomanip>
#define LL long long
const int N=1e4+5;
using namespace std;
struct Node{
int m,v,i; //m质量,v速度,i编号
}a[N];
bool cmp(Node a,Node b) //让m从小到大进行排序
{
if(a.m==b.m) return a.v>b.v;
return a.m<b.m;
}
int f[N][3];
int main()
{
int i=1;
while(cin>>a[i].m>>a[i].v) //因为输入数据不确定,所以要用while输入
{
a[i].i=i;
i++;
}
int n=i-1;
sort(a+1,a+1+n,cmp); //进行排序
for(int i=n;i>=1;i--)
{
int l=0,k; //用l记录最大长度,k记录最大长度的位置
f[i][1]=1; //初始化
for(int j=i+1;j<=n;j++)
if(a[i].m<a[j].m&&a[i].v>a[j].v&&l<f[j][1])
{
l=f[j][1];
k=j;
}
if(l>0) //l>0,即i后面存在比i大的数
{ //更新f的值
f[i][1]=l+1;
f[i][2]=k;
}
}
int k=1;
for(int i=1;i<=n;i++) //找到最长上升子序列的起始位置
if(f[k][1]<f[i][1]) k=i;
cout<<f[k][1]<<endl; //输出长度
while(k!=0) //输出每个数的位置
{
cout<<a[k].i<<endl;
k=f[k][2];
}
return 0;
}