Milking Time

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43

题目大意:一头奶牛现在要工作n小时,在这n小时里有m个任务。奶牛每完成一个任务后要休息r小时。给出这m个任务的开始时间、结束时间和得到的奶量。求在这m个任务中如何选择能得到最大的产奶量。

题目分析:

  1. 状态表示:f[i] //表示1-i小时的最大产奶量
  2. 预处理:因为奶牛在完成了一个任务的时候会休息r小时,我们可以将这r小时加到区间右端点上。(即:a[i].r+=rest)
    注意:在状态计算的时候也要往后算到f[n+rest]。
    然后将这m个区间按照右端点进行排序(按左端点进行排序好像也可以,但那样计算方法也会不一样)。
  3. 状态计算:有两个状态
    1)当第i小时没有完成某个任务产奶时,f[i]=f[i-1] //1一i小时的最大产奶量等于1一i-1小时的产奶量
    2)当第i个小时完成了某些任务产奶时,即i==a[k].r(1<=k<=m),有两个选择(选择该任务和不选该任务),取最大值即可。f[i]=max(f[i-1],f[a[k].l]+a[k++].c)

代码如下:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <map> 
#include <queue>
#include <algorithm>
#include <iomanip>
#define LL long long
const int N=1e3+5,M=1e6+5;
using namespace std;
struct Node{
	int l,r,c;     //每个任务的开始时间、结束时间以及产奶量
	bool operator< (const Node &a) const
	{
		return r<a.r;
	}
}a[N];
int f[M];
int main()
{
	int n,m,rest;
	cin>>n>>m>>rest;
	for(int i=1;i<=m;i++)
	{
	    cin>>a[i].l>>a[i].r>>a[i].c;
	    a[i].r+=rest;     //预处理
	}
	sort(a+1,a+1+m);      //按右端点进行排序
	int ans=0,k=1;
	for(int i=1;i<=n+rest;i++)
	{
		f[i]=f[i-1];    //第一种情况没有任何限制条件
		//因为右端点从小到大排过序,因此计算后直接让k++,取下一个即可
		while(a[k].r==i) f[i]=max(f[i],f[a[k].l]+a[k++].c);
	}   //以i为右端点的区间可能有多个,要用while
	cout<<f[n+rest]<<endl;    //f[n+rest]即为答案
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
Based on the following story, continue the story by writing two paragraphs, paragraph 1 beginning with "A few weeks later, I went to the farm again. " and paragraph 2 beginning with "I was just about to leave when the hummingbird appeared."respectively with 150 words. I was invited to a cookout on an old friend's farm in western Washington. I parked my car outside the farm and walked past a milking house which had apparently not been used in many years.A noise at a window caught my attention,so I entered it. It was a hummingbird,desperately trying to escape. She was covered in spider-webs and was barely able to move her wings. She ceased her struggle the instant I picked her up. With the bird in my cupped hand, I looked around to see how she had gotten in. The broken window glass was the likely answer. I stuffed a piece of cloth into the hole and took her outside,closing the door securely behind me. When I opened my hand, the bird did not fly away; she sat looking at me with her bright eyes.I removed the sticky spider-webs that covered her head and wings. Still, she made no attempt to fly.Perhaps she had been struggling against the window too long and was too tired? Or too thirsty? As I carried her up the blackberry-lined path toward my car where I kept a water bottle, she began to move. I stopped, and she soon took wing but did not immediately fly away. Hovering,she approached within six inches of my face. For a very long moment,this tiny creature looked into my eyes, turning her head from side to side. Then she flew quickly out of sight. During the cookout, I told my hosts about the hummingbird incident. They promised to fix the window. As I was departing, my friends walked me to my car. I was standing by the car when a hummingbird flew to the center of our group and began hovering. She turned from person to person until she came to me. She again looked directly into my eyes, then let out a squeaking call and was gone. For a moment, all were speechless. Then someone said, “She must have come to say good-bye.”
02-12
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lwz_159

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值