find your present (2)

Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Sample Input
5
1 1 3 2 2
3
1 2 1
0
Sample Output
3
2

题目意思是说:你需要找的数字会出现基数次,跟别的数字不同;

关键的解题思路: 数学运算, 你所要找的是一个不同于其他的所有数字, 可以用异或运算;

关于异或运算:一个数和0做异或运算还是这个数本身, 两个相同的数做异或运算 结果为0;


import java.util.Scanner;
public class PracticeII {
public static void main(String[] args) {
Scanner sc= new Scanner(System.in);
int n,result;
while(sc.hasNext()){
n = sc.nextInt();
result = 0;
if(n==0) break;
for(int i=0; i<n; i++){
result ^=  sc.nextInt();
}
System.out.println(result);
}
}
}


但是上面这段代码总是抛出  Memory Limit Exceeded     内存超限,  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值