Rightmost Digit

Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.

In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.


题目的意思是:求出n的n次幂的个位上的数;

任何两个数相乘的最低位一定是它们最低位相乘所得结果的最低位,并且循环不会超过4次;


import java.util.Scanner;
public class PracticeIII {
public static void main(String[] args) {
Scanner sc= new Scanner(System.in);
int t,a,b,c,d;
long n;
t = sc.nextInt();
while((t--)>0){
n = sc.nextLong();
a = (int) (n%10);
b = a * a % 10;
c = b * a % 10;
d = c * a % 10;
switch((int)n % 4){
case 0 : 
System.out.println(d);
break;
case 1 :
System.out.println(a);
break;
case 2 :
System.out.println(b);
break;
case 3 :
System.out.println(c);
break;
}
}
}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值