POJ 3159

POJ 3159 Candies(差分规划+SPFA)

Candies
Time Limit: 1500MS	 	Memory Limit: 131072K
Total Submissions: 18737	 	Accepted: 4930
Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. 
He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just
 got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not 
exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy
 and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that 
 kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4
Sample Output

5
//spfa+stack 求最短路径    //这里求最大相差糖果数,意思是在各位同学的意愿下,班长比班级的表现最差的同学相差的最大糖果树 
//意为在所有情况下,班长比这位同学相差的最小糖果数 
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

const int MAXN=30010;
const int MAXE=150010;
const int INF=0x3f3f3f3f;
int head[MAXN];//每个结点的头指针
int vis[MAXN];//在队列标志

int Q[MAXN];//堆栈
int dist[MAXN];

struct Edge
{
    int to;
    int v;
    int next;
}edge[MAXE];//边数组 
int tol;

void add(int a,int b,int v)//加边//b比a大v 
{
    edge[tol].to=b;//边的起点 
    edge[tol].v=v;//边的权值 
    edge[tol].next=head[a];//记录这条边的顶点的标号 
    head[a]=tol++;//tol的初始化为0 ,改变此顶点的标号 
}

void SPFA(int start,int n)
{
    int top=0;
    for(int v=1;v<=n;v++)//初始化
    {
        if(v==start)
        {
            Q[top++]=v;
            vis[v]=true;
            dist[v]=0;
        }
        else
        {
            vis[v]=false;
            dist[v]=INF;
        }
    }
    while(top!=0)
    {
        int u=Q[--top];
        vis[u]=false;
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            if(dist[v]>dist[u]+edge[i].v)
            {
                dist[v]=dist[u]+edge[i].v;                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        
                if(!vis[v])
                {
                    vis[v]=true;
                    Q[top++]=v;
                }
            }
        }
    }
}
int main()
{
   // freopen("in.txt","r",stdin);
  //  freopen("out.txt","w",stdout);
    int n;
    int M;
    int a,b,c;
    while(scanf("%d%d",&n,&M)!=EOF)
    {
        tol=0;//加边计数,这个不要忘
        memset(head,-1,sizeof(head));
        while(M--)
        {
            scanf("%d%d%d",&a,&b,&c);
            //b-a<=c
            add(a,b,c);
            //大-小<=c ,有向边(小,大):c
        }
        SPFA(1,n);
        printf("%d\n",dist[n]);
    }
    return 0;
}
注:
  spfa+stack
  spfa+queue
  一个是bfs(广搜)加迭代
  一个是dfs(深搜)加迭代
  迭代:就是不断的做,做到没有更有的解为止
  或者是不断的做,做到逼近答案为止
  栈比队列更快更节省空间

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值