POJ 1068模拟题

1 篇文章 0 订阅
Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24757 Accepted: 14564

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
 
题意大意是有一个只有左括号或右括号的字符串,给你一排数字代表每个右括号之前有多少个左括号,然后让你计算每一对括号之间包含着多少对括号。
我的大致思路为先用这个数组把字符串给还原,然后从左到右遍历字符串,遇到右括号便往回寻找,设置一个变量标记此括号前右括号的个数,若遇到左括号如果变量个数不为零则优先消去,否则匹配完成。
传送门
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>

using namespace std;

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int arr[25],n;
        cin>>n;
        for(int i=0;i<n;i++) cin>>arr[i];
        char a[110];
        int ans=0;
        for(int i=0;i<n;i++)
        {
            if(i==0)
            {
                for(int j=0;j<arr[0];j++) a[ans++]='(';
                a[ans++]=')';
            }
            else
            {
                int tt=arr[i]-arr[i-1];
                while(tt--)
                {
                     a[ans++]='(';
                }
                 a[ans++]=')';
            }
        }
        int flag=0;
        for(int i=0;i<ans;i++)
        {
            if(a[i]==')')
            {
                int ss=0,xiao=0;
                for(int j=i-1;j>=0;j--)
                {
                    if(a[j]==')')
                    {
                        ss++;
                        xiao++;
                    }
                    else if(a[j]=='(')
                    {
                        if(xiao!=0) xiao--;
                        else break;
                    }
                }
                if(flag) cout<<" ";
                cout<<ss+1;
                flag++;
            }
        }
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值