POJ 2442 优先队列

Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 8859 Accepted: 2938

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4
 
很简单很暴力的一个思路,很好理解,直接上代码。
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<stack>
#include<algorithm>

using namespace std;
priority_queue<int>B;
int a[2123],b[2123];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m;
        cin>>m>>n;
        for(int i=1;i<=102;i++) while(!B.empty()) B.pop();
        for(int j=1;j<=n;j++) scanf("%d",&a[j]);
        for(int i=2;i<=m;i++)
        {
            for(int j=1;j<=n;j++) scanf("%d",&b[j]);
            for(int j=1;j<=n;j++) B.push(a[j]+b[1]);
            for(int j=2;j<=n;j++)
            {
                for(int h=1;h<=n;h++)
                {
                    if(a[h]+b[j]<B.top())
                    {
                        B.pop();
                        B.push(a[h]+b[j]);
                    }
                }
            }
            for(int j=1;j<=n;j++)
            {
                a[j]=B.top();
                B.pop();
            }
        }
        sort(a+1,a+1+n);
        for(int i=1;i<=n;i++) cout<<a[i]<<" ";
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值