POJ-2442 二叉堆

Description
Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It’s clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?
Input
The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.
Output
For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.
Sample Input
1
2 3
1 2 3
2 2 3
Sample Output
3 3 4

每两个序列求前n小合并为一新序列继续参与计算,最后剩下的一个序列即为答案
sort(a,a+n),sort(b,b+n)
if A[i]+B[j] is k- th Min:
min(A[i+1]+B[j],A[i]+B[j+1]) is the k+1- th Min
为避免重复,规定 j+1产生新答案 则以后只能增加 j ,不增加 i
bfs n次,开始放入(0,0,0)
取出堆顶(i,j,flag)
push(i,j+1,1)
if flag==0:
push(i+1,j,0)
每次取出堆顶A[i]+B[j],即为前n小

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
#define op <   //小根堆
using namespace std;
typedef long long ll;
const int N=1e4+5;
struct Tuple{
	int i,j,flag;
	Tuple(){}
	Tuple(int i,int j,int flag):i(i),j(j),flag(flag){};
}heap[N],tmp;
int a[N],b[N],c[N];
struct Binary_heap{
	int sz;
	#define H(id) (a[heap[id].i]+b[heap[id].j])
	void up(int p){
		while(p>1&&H(p) op H(p>>1))swap(heap[p],heap[p>>1]),p>>=1;
	}
	void push(int i,int j,int flag){
		heap[++sz]=Tuple(i,j,flag);
		up(sz);
	}
	void down(int p){
		int ls=p<<1;
		while(ls<=sz){
			if(ls<sz&&H(ls|1) op H(ls))ls|=1;
			if(H(ls) op H(p))swap(heap[ls],heap[p]),p=ls,ls=p<<1;
			else break;
		}
	}
	void pop(){
		heap[1]=heap[sz--];
		down(1);
	}
	Tuple top(){
		return heap[1];
	}
}P;
int t,m,n;
void bfs(){
	P.sz=0,P.push(0,0,0);
	for(int i=0;i<n;++i){
		tmp=P.top(),c[i]=H(1),P.pop();
		P.push(tmp.i,tmp.j+1,1);
		if(!tmp.flag)P.push(tmp.i+1,tmp.j,0);
	}
}
int main(){
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&m,&n);
		for(int i=0;i<n;++i)scanf("%d",a+i);
		sort(a,a+n);
		for(int i=1;i<m;++i){
			for(int j=0;j<n;++j)scanf("%d",b+j);
			sort(b,b+n);
			bfs();
			for(int i=0;i<n;++i)a[i]=c[i];
		}
		for(int i=0;i<n;++i)printf("%d ",a[i]);
		putchar('\n');
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值