POJ 3267 The Cow Lexicon



The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9766 Accepted: 4682

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:   W  and   L  
Line 2:   L  characters (followed by a newline, of course): the received message  
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

一个动态规划题,一开始自己没想出来,知道看了题解才恍然大悟。

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int dp[512];
char a[512];
char b[612][612];

int main()
{
    int n,m;
    cin>>m>>n;
    memset(dp,0,sizeof(dp));
    dp[0]=1;
    cin>>a;
    for(int i=0;i<m;i++) scanf("%s",&b[i]);
    for(int i=1;i<n;i++)
    {
        dp[i]=dp[i-1]+1;
        for(int j=0;j<m;j++)
        {
            int ll=strlen(b[j])-1;
            int k=i;
                while(k>=ll&&k>=0&&ll>=0)
                {
                    if(a[k]==b[j][ll]) ll--;
                    k--;
                }
                if(ll<0)
                {
                    if(dp[i]>dp[k]+i-k-strlen(b[j])) dp[i]=dp[k]+i-k-strlen(b[j]);
                }
        }
    }
    cout<<dp[n-1]<<endl;
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值