POJ 3349

5 篇文章 0 订阅
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 38027 Accepted: 9963

Description

You may have heard that no two snowflakes(雪花) are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical(同一的). Each snowflake has six arms. For each snowflake, your program will be provided with a measurement(测量) of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input(投入) will contain a single integer(整数) n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake(雪花). Each snowflake will be described by a line containing six integers(整数) (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise(顺时针方向的) or counterclockwise(反时针方向的)), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct(明显的), your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical(同一的) snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
#define inf 1200007

using namespace std;

struct node
{
    int arm[7];
    int next;
}a[1200011];

int hs[1200011];
int ans=0;
int t[8];

bool jz(int sum)
{
    bool flag=true;
    int en=sum;
    while(sum!=-1)
    {
        for(int j=0;j<6;j++)
        {
            flag=true;
            for(int k=0;k<6;k++)
            {
         //   cout<<a[sum].arm[k]<<" "<<t[(k+j+12)%6]<<endl;
                if(a[sum].arm[k]!=t[(k+j+12)%6])
                {
                    flag=false;
                   break;
                }
            }
        //    cout<<endl;
            if(flag) return true;
        }
        sum=a[sum].next;
    }
    sum=en;
     while(sum!=-1)
    {
        for(int j=0;j<6;j++)
        {
            flag=true;
            for(int k=0;k<6;k++)
            {
         //   cout<<a[sum].arm[k]<<" "<<t[(k-j+12)%6]<<endl;
                if(a[sum].arm[5-k]!=t[(k+j+12)%6])
                {
                    flag=false;
                   break;
                }
            }
         //   cout<<endl;
            if(flag) return true;
        }
        sum=a[sum].next;
    }
    return false;
}

void push(int ss)
{
    for(int i=0;i<6;i++) a[ans].arm[i]=t[i];
    a[ans].next=hs[ss];
    hs[ss]=ans;
    ans++;
}

int main()
{
    int n,flag=0;
    for(int i=0;i<=1200010;i++) hs[i]=-1;
    cin>>n;
    while(n--)
    {
        unsigned  sum=0;
        for(int i=0;i<6;i++)
        {
            scanf("%d",&t[i]);
            sum+=t[i];
        }
        if(flag) continue;
        unsigned ss=sum%inf;
        if(hs[ss]==-1) push(ss);
        else if(jz(hs[ss])) flag=1;
        else  push(ss);
    }
    if(flag) cout<<"Twin snowflakes found."<<endl;
    else cout<<"No two snowflakes are alike."<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值