POJ 1159 Palindrome

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 60328 Accepted: 21010

Description

A   palindrome (回文)  is a   symmetrical (匀称的)  string, that is, a string read   identically (同一地)  from left to right as well as from right to left. You are to write a program which, given a string, determines the   minimal (最低的)  number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be   transformed (改变)  into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard   input (投入). The first line contains one   integer (整数): the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from   uppercase (以大写字母印刷)  letters from 'A' to 'Z',   lowercase (小写字母)  letters from 'a' to 'z' and digits (数字)  from '0' to '9'. Uppercase and lowercase letters are to be considered   distinct (明显的).

Output

Your program is to write to standard   output (输出). The first line contains one   integer (整数), which is the desired   minimal (最低的)  number.

Sample Input

5
Ab3bd

Sample Output

2

给你一个字符串,让你计算最少再加进去几个字符,就可以让这个字符串变成回文串。
一个最长公共子序列的问题,求出这个字符串的顺序和逆序的最长公共子序列,所求即为字符串的长度减去减去最长公共子
序列的长度,因为你只要在不是最长公共子序列的字符在这个字符串的中与这个字符对应的位置再插入一个相同的字符串,
他们就对称了。

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

char a[5009],b[5009];
short dp[5006][5006];

int main()
{
    int n;
    while(cin>>n)
    {
         scanf("%s",a);
        memset(dp,0,sizeof(dp));
        for(int i=n-1;i>=0;i--) b[n-i-1]=a[i];
        for(int i=0;i<n;i++)
        for(int j=0;j<n;j++){
        if(a[i]==b[j]) dp[i+1][j+1]=dp[i][j]+1;
        else dp[i+1][j+1]=dp[i+1][j]>dp[i][j+1]?dp[i+1][j]:dp[i][j+1];
        }
        cout<<n-dp[n][n]<<endl;
        }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值