输出某个月的天数

95 篇文章 0 订阅
87 篇文章 0 订阅
/*描述
 输入一个年份与月份,输出该年该月的天数。
 输入
 2个整数表示年份与月份。
 输出
 天数。
 样例输入
 2012 2 
 2011 2
 1999 4
 1998 5
 样例输出
 29
 28
 30
 31*/
import java.util.*;

public class Main5 {
	public static int year, month;

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (sc.hasNext()) {
			year = sc.nextInt();
			month = sc.nextInt();
			if (year % 400 == 0 || (year % 100 != 0 && year % 4 == 0)) {
				if (month == 2) {
					System.out.println(29);
				} else {
					if (month < 8 && month % 2 != 0 || month >= 8
							&& month % 2 == 0) {
						System.out.println(31);
					} else {
						System.out.println(30);
					}
				}
			} else {
				if (month == 2) {
					System.out.println(28);
				} else {
					if (month < 8 && month % 2 != 0 || month >= 8
							&& month % 2 == 0) {
						System.out.println(31);
					} else {
						System.out.println(30);
					}
				}
			}
		}
	}
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值