Uva1339 Ancient Cipher 古代密码

题目来自:https://cn.vjudge.net/problem/UVA-1339
Ancient Roman empire had a strong government system with various departments, including a secret
service department. Important documents were sent between provinces and the capital in encrypted
form to prevent eavesdropping. The most popular ciphers in those times were so called substitution
cipher and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all
letters must be different. For some letters substitute letter may coincide with the original letter. For
example, applying substitution cipher that changes all letters from `A' to `Y' to the next ones in the
alphabet, and changes `Z' to `A', to the message \VICTORIOUS" one gets the message \WJDUPSJPVT".
Permutation cipher applies some permutation to the letters of the message. For example, ap-
plying the permutation 〈 2, 1, 5, 4, 3, 7, 6, 10, 9, 8 〉 to the message \VICTORIOUS" one gets the message
\IVOTCIRSUO".
It was quickly noticed that being applied separately, both substitution cipher and permutation
cipher were rather weak. But when being combined, they were strong enough for those times. Thus,
the most important messages were rst encrypted using substitution cipher, and then the result was
encrypted using permutation cipher. Encrypting the message \VICTORIOUS" with the combination of
the ciphers described above one gets the message \JWPUDJSTVP".
Archeologists have recently found the message engraved on a stone plate. At the rst glance it
seemed completely meaningless, so it was suggested that the message was encrypted with some substi-
tution and permutation ciphers. They have conjectured the possible text of the original message that
was encrypted, and now they want to check their conjecture. They need a computer program to do it,
so you have to write one.
Input
Input le contains several test cases. Each of them consists of two lines. The rst line contains the
message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so
the encrypted message contains only capital letters of the English alphabet. The second line contains
the original message that is conjectured to be encrypted in the message on the rst line. It also contains
only capital letters of the English alphabet.
The lengths of both lines of the input le are equal and do not exceed 100.
Output
For each test case, print one output line. Output `YES' if the message on the rst line of the input le
could be the result of encrypting the message on the second line, or `NO' in the other case.
Sample Input
JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES
Sample Output
YES
NO
YES
YES
NO
题目描述:大意就是说A字符串通过替换和随意排序得到B字符串(也就是字母之间的加密),给你A字符串和B字符串,让你判断A字符串是否能得到B字符串。

解题思路:无论如何替换和排序,字母是一一对应的,也就是说A字符串和B字符串对应字母的个数相等,需要对个数排下序,就可解决,虽然是模拟,但比较难想。

AC代码:
 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=105;
string str1,str2;
int cnt[26],cnt1[26];
int main(){
    while(cin>>str1>>str2){
        int len=str1.length();
        memset(cnt,0,sizeof(cnt));
        memset(cnt1,0,sizeof(cnt1));
        for(int i=0;i<len;i++){
            cnt[str1[i]-'A']++;
            cnt1[str2[i]-'A']++;
        }
        int flag=0;
        sort(cnt,cnt+26);
        sort(cnt1,cnt1+26);
        for(int i=0;i<26;i++){
           if(cnt[i]!=cnt1[i]){
            cout<<"NO"<<endl;
            flag=1;
            break;
        }
    }
    if(!flag)
    cout<<"YES"<<endl;
    }
return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值