DFS_6

Description

Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve 
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one. 
You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve. 

Input

The input contains multiple test cases. 
Each test case include, first one integer n ( 2< n < 15).express the number of problem. 
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j. 

Output

For each test case output the maximum number of problem zty can solved. 


Sample Input

3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0

Sample Output

3
2
4

Hint

   
   
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1.

又是一道深搜题,题意是这个人要解决问题,但是他有一个死脑筋就是要从易到难按顺序(毕竟人喜欢挑战高难度)。题中给出了一堆数,Tij表示解决了问题i后要花费时间Tij去解决问题j。利用dfs时注意每次要比较当前的时间和所给时间的关系就好

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>

using namespace std;

const int MAX=15+10;
int s[MAX][MAX],sum,n;
bool mark[MAX];

void dfs(int id,int num,int source){
	for(int i=0;i<n;++i){
		if(mark[i] || s[id][i]<source) continue;
		mark[i]=true;
		dfs(i,num+1,s[id][i]);
		mark[i]=false;
	}
	sum=max(sum,num);
}

int main(){
	while(cin>>n){
		for(int i=0;i<n;++i){
			for(int j=0;j<n;++j)cin>>s[i][j];
		}
		memset(mark,false,sizeof mark);
		sum=0;
		mark[0]=true;
		dfs(0,1,0);
		cout<<sum<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值