dp_4

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence (  a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
求最长上升子序列

利用动态规划

用dp[k]表示以a[k]作为终点的最大上升子序列
则:
dp[1] = 1;
dp[k] = Max (dp[i]:1 <= i < k 且 a[i ]< a[k] 且 k != 1) + 1.

#include<stdio.h>
#define MAXN 1000
int dp[MAXN+10],a[MAXN+10];//a数组记录输入的序列
int main()
{
    int n,i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
       scanf("%d",&a[i]);
    dp[1]=1;
    for(i=2;i<=n;i++)
    {
        int temp=0;
        for(j=1;j<i;j++)
        {
           if(a[i]>a[j])
              if(temp<dp[j])
                temp=dp[j];
        }
        dp[i]=temp+1;//dp状态在这里才发生改变
    }
    int maxlen=0;
    for(i=1;i<=n;i++)
        if(maxlen<dp[i])
           maxlen=dp[i];
    printf("%d\n",maxlen);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值