dijkstra+矩阵逆转+vector邻接表(2021-8-6)

Silver Cow Party

题意
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional(单向的) (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units(单位) of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal(最优的) route with the shortest time. A cow’s return route might be different from her original(起初的) route to the party since(因为) roads are one-way(单向的).

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively(各自的): N, M, and X
Lines 2…M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse(横穿).

Output
Line 1: One integer: the maximum of time any one cow must walk.

Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output
10

Hint(提示)
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

坑点:超时
解决:矩阵转置-多个点到一个点,转置后,一个点到多个点

邻接表:(缺点:代码大量重复)

#include<iostream>
#include<vector>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn=1e4+5;
const int INF=0x7fffffff;
struct Edge{
	int to;
	int val;
};
int n,m,x;
Edge edge;
vector<Edge> mp[maxn];
vector<Edge> rmp[maxn];
bool vis[maxn];
int dis[maxn];
bool vis_go[maxn];
int dis_go[maxn];
int num[maxn];//每只猪用时 
void dijkstra(int start){
	fill(dis,dis+n+1,INF);//[1,n) 初始化
	memset(vis,false,sizeof(vis));
	dis[start]=0;//自己到自己的距离为0
	
	while(1){
		
		int top=-1;
		int min_val=INF,min_index=-1;
		for(int i=1;i<n+1;i++){
			if(!vis[i]&&min_val>dis[i]){
				min_val=dis[i]; 
				min_index=i;

			}
		} 
		top=min_index; 
		
		
		if(top==-1){
			return;
		} 
		vis[top]=1;
		
		for(int i=0;i<mp[top].size();i++){//松弛 
			edge=mp[top][i];
			if(dis[top]+edge.val < dis[edge.to] ){
				dis[edge.to]=dis[top]+edge.val;
			}
		} 
		
	
		
	}

} 
void dijkstra_go(int start){
	fill(dis_go,dis_go+n+1,INF);//[1,n) 初始化
	memset(vis_go,false,sizeof(vis_go));
	dis_go[start]=0;//自己到自己的距离为0
	
	while(1){
		
		int top=-1;
		int min_val=INF,min_index=-1;
		for(int i=1;i<n+1;i++){
			if(!vis_go[i]&&min_val>dis_go[i]){
				min_val=dis_go[i]; 
				min_index=i;

			}
		} 
		top=min_index; 
		
		
		if(top==-1){
			return;
		} 
		vis_go[top]=1;
		
		for(int i=0;i<rmp[top].size();i++){//松弛 
			edge=rmp[top][i];
			if(dis_go[top]+edge.val < dis_go[edge.to] ){
				dis_go[edge.to]=dis_go[top]+edge.val;
			}
		} 
		
	
		
	}

} 
int main(){
	
	while(cin>>n>>m>>x){
		for(int i=1;i<n+1;i++){
			mp[i].clear();
		}
		for(int i=1;i<n+1;i++){
			rmp[i].clear();
		}
		while(m--){//建图 
			int u,v,val;
			cin>>u>>v>>val;
			edge.to=v;
			edge.val=val;
			mp[u].push_back(edge);
			edge.to=u;
			rmp[v].push_back(edge); 
		}
		
		dijkstra(x);//回 
		for(int i=1;i<n+1;i++){
			num[i]=dis[i];
		}
		dijkstra_go(x);//去
		for(int i=1;i<n+1;i++){
			num[i]+=dis_go[i];
		}
		sort(num+1,num+n+1);
		cout<<num[n]<<endl;
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值