HDU 1312 Red and Black(BFS,DFS)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16081    Accepted Submission(s): 9912


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source

题解:经典的搜索(bfs,dfs也可以)

TLE代码.....:搜得太深了。。。
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
typedef long long LL;
using namespace std;
int w,h;
char z[21][21];
int dfs(int i,int j){
	if(i<1||j>h||j<1||j>w)return 0;
	
	if(z[i][j]!='#')
	{
		z[i][j]='#';
		return 1+dfs(i-1,j)+dfs(i,j-1)+dfs(i+1,j)+dfs(i,j+1);  //TLE.... 
    }
	else return 0; 
}
int main()
{
	
     while(cin>>w>>h){
     	if(w==0&&h==0)break;
     	
     	for(int i=1;i<=h;i++)
     	  for(int j=1;j<=w;j++)
     	  	cin>>z[i][j];
     	  	for(int i=1;i<=h;i++){
     	  		for(int j=1;j<=w;j++)
     	  		   if(z[i][j]=='@')
     	  		   cout<<dfs(i,j)<<endl;
     	  	}
     } 
    return 0;
}

AC代码:(BFS)
#include <stdio.h>
#include <queue>
#include <string.h>
#include <algorithm>
using namespace std;
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}}; //扩展的四个方向
char map[33][33];
int vis[33][33];
int n,m;
int sum;
struct node
{
	int x,y;
}
f[333];
#define inf 0xfffffff
void bfs(int x,int y)
{
	int i;
	queue<node>q;
	node st,ed;
	st.x=x;
	st.y=y;
	q.push(st);
	while(!q.empty())  //队列非空
	{
		st=q.front();
		q.pop();       
		for(i=0;i<4;i++)
		{
			ed.x=st.x+dir[i][0];
			ed.y=st.y+dir[i][1];
			if(ed.x>=n ||ed.y>=m ||ed.x<0 ||ed.y<0 ||map[ed.x][ed.y]=='#' ||map[ed.x][ed.y]=='@') //判断越界
				continue;
			map[ed.x][ed.y]='@';  //标志已经遍历过的
			sum++;
			q.push(ed);    
		}
	}
}
int main()
{
	int i,j,x,y;
	while(scanf("%d%d",&m,&n)!=EOF&&n!=0 &&m!=0)
	{
		for(i=0;i<n;i++)
			scanf("%s",map[i]);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='@')  //寻找起始点
				{
					x=i;
					y=j;		 
				}
			}
			sum=1;
			bfs(x,y);
			printf("%d\n",sum);
	}
	return 0;
}
//广搜

AC代码:(DFS)
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
char map[33][33];
int vis[33][33];
int n,m;
int sum;
#define inf 0xfffffff
void dfs(int x,int y)
{
    int sx,sy,i;
    sum++;
    for(i=0;i<4;i++)
    {
        sx=x+dir[i][0];
        sy=y+dir[i][1];
        if(sx>=n ||sy>=m ||sx<0 ||sy<0 ||map[sx][sy]=='#' ||map[sx][sy]=='@')
            continue;
          map[sx][sy]='@';
              dfs(sx,sy);
    } 
}
int main()
{
    int i,j,x,y;
    while(scanf("%d%d",&m,&n)!=EOF&&n!=0 &&m!=0)
    {
        for(i=0;i<n;i++)
            scanf("%s",map[i]);
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            {
                if(map[i][j]=='@')
                {
                    x=i;
                    y=j;         
                }
            }
            sum=0;
            dfs(x,y);
            printf("%d\n",sum);
    }
    return 0;
}
//深搜



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值