HDU1312 Red and Black(BFS)

问题描述:
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
…@…
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

AC代码:

#include<stdio.h>
#include<string.h>

char mp[25][25];
int book[25][25],sum,n,m;

struct node
{
    int x,y;
} Q[410];

void bfs(int x,int y)
{
    int nx[4][2]={{0,-1},{1,0},{0,1},{-1,0}};
    int head=1,tail=2;
    Q[head].x=x;
    Q[head].y=y;
    while(head<tail)
    {
        for(int i=0;i<4;i++)
        {
            int tx=Q[head].x+nx[i][0];
            int ty=Q[head].y+nx[i][1];
            if(tx<0||ty<0||tx>=n||ty>=m) continue;
            if(book[tx][ty]==0&&mp[tx][ty]=='.')
            {
                Q[tail].x=tx;
                Q[tail].y=ty;
                book[tx][ty]=1;
                sum++;
                tail++;
            }
        }
        head++;
    }
    return;
}

int main()
{
    while(~scanf("%d %d",&m,&n)&&m+n)
    {
        getchar();
        int i,j,sx,sy;
        memset(book,0,sizeof(book));
        for(i=0;i<n;i++)
        {
            scanf("%s",mp[i]);
            for(j=0;j<m;j++)
            {
                if(mp[i][j]=='@')
                {
                    sum=1;
                    book[i][j]=1;
                    sx=i;
                    sy=j;
                }
            }
        }
        bfs(sx,sy);
        printf("%d\n",sum);
    }
    return 0;
}

关于深度优先搜索(dfs)与广度优先搜索(bfs):

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值