HDU 1395 2^x mod n = 1(暴力枚举)

2^x mod n = 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15721    Accepted Submission(s): 4870

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input
One positive integer on each line, the value of n.

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.
You should replace x and n with specific numbers.

Sample Input
  
  
2 5

Sample Output
  
  
2^? mod 2 = 1 2^4 mod 5 = 1

Author
MA, Xiao

Source

题解:暴力枚举....

TLE代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int main()
{
    int x,n;
	while(cin>>n)
	{
		int k=0;
		for(int i=1;i<=5000;i++)
		{
			if((int)pow(2,(double)i)%n==1){
				printf("2^%d mod %d = 1\n",i,n);break;
			}
			
			k++;
		}
		if(k==5000)
		cout<<"2^? mod "<<n<<" = 1"<<endl;

	} 
	
	return 0;	
}

AC代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int main()
{

	int k,m,x,n;
	while(cin>>n)
	{
		k=1;
		x=2;
		if(n%2==0||n==1)
			cout<<"2^? mod "<<n<<" = 1"<<endl;
		else
		{
			while(k++)
			{
				
				x*=2;
				x=x%n;
				if(x==1)
				break;
			}
		cout<<"2^"<<k<<" mod "<<n<<" = 1"<<endl;
	}
	}
	return 0;	
}



 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值